0

I am on a Ubuntu 14.04 LTS machine, regularly updated.
I downloaded early this year the printer and scanner drivers for my Epson stylus SX235W from the Epson download page. The scanner driver is version 1.0.0 (iscan-bundle-1.0.0.x64.deb.tar.gz).
The device has a dedicated static ip in my router: 192.168.0.102
Once installed my all-in-one device worked fine via wifi until recently: the printer still works as before but the scanner is no longer recognised.
I used to use simple scan because the image scan! Epson Utility did not work (probably because uses as backend epkowa which was not configured properly.)
Now even simple scan does not work any more:

Failed to scan
No scanners available. Please connect a scanner

The output of scanimage -L is:

asarluhi@SATELLITE-L50-A-161:~ $ scanimage -L

No scanners were identified.

I tried to install sane, which was not installed by default, but xsane too does not detect the scanner: no devices available.

With the usb cable connected there are no relevant issues, so the problem I suppose is with the wireless network communication with the scanner.
With the usb cable, scanimage -L output is:

asarluhi@SATELLITE-L50-A-161:~ $ scanimage -L
device `epkowa:usb:003:003' is a Epson Stylus SX235W/NX230/TX230W Series flatbed scanner

The only issue is that, as I said before, being the epkowa backend not configured, only simple scan did its job. Xscan returned failed to open device 'epkowa:usb:003:003': Device busy.

I tried to edit file etc/sane.d/epkowa.conf adding the following line:

net 192.168.0.102

With this change, with wireless network communication, when I launch any scanner utility or scanimage -L the process requires more time to produce a response, but the result is still the same:

simple scan:

Failed to scan
Unable to start scan

xsane

no devices available

What would you suggest to do?

1

Are you sure that firewall is not blocking the connection? I had similar issue which solved by changing ufw settings. It can be tested by:

root@joker:~# ufw status
Status: active
root@joker:~# ufw disable
Firewall stopped and disabled on system startup

joker@joker:~$ scanimage -L
device `epson2:net:AAA.BBB.CCC.DDD' is a Epson PID 0885 flatbed scanner

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.