I've got a Dell Precision 5510 (skylake) hooked to an external monitor via a Displayport (though same problems came up with HDMI) using two different Displaylink docks. When on Intel graphics, the framerate on the external monitor is appalling - around 1fps when running glxspheres. Using optirun, it's way more (200 fps, same as on laptop monitor). If I switch to nvidia Prime graphics, the laptop monitor shuts off completely, but the external monitor performs very well (2000+ fps).

Using Intel graphics, Chrome became unusable on the second monitor, until I disabled hw accelration in Chrome settings, when it became quite usable. A big problem I'm facing is that the terminal on the external monitor is extremely laggy due to the 1fps problem. Is there a way to overcome this problem, or even disable hardware acceleration entirely; I do have tonnes of cpu to spare.

Update: It appears if I connect the monitor with an HDMI cable directly (instead of through either of the Displaylink docks, then the second monitor gives 60fps using intel graphics. It does mean running another cable, but I guess that's what I'll have to do for now.

  • 1
    My update is a workaround, and still hope to find a better solution. – ashic Oct 24 '16 at 12:50
  • I have the exact same problem, and there are others like us. There was something in the upgrade from 16.04 + displaylink "fixes" that causes extreme lag. I only get ~ 1 fps. For more info see support.displaylink.com/forums/… – troglobit Nov 4 '16 at 9:29
  • I had the same problem, and came to the same conclusion. I got a usb-c to hdmi cable and now everything is so much faster. I tried updating to the latest Displaylink driver but no luck. I wish I didn't waste my money on the Displaylink. FYI, I have a Dell XPS 13 9360. – mangoDrunk Dec 23 '17 at 0:07

I myself am not a Linux Guru like most other people here, but I found something that at least worked for me:

  • Go to /etc/X11/xorg.conf.d/ (or create said folder)
  • Search if you already have a *-intel.conf file
  • If yes, add this line before EndSection: Option "VSync" "false"
  • If no, create the file 20-intel.confand write this:

    Section "Device"
        Identifier  "Intel"
        Driver      "intel"
        Option      "VSync" "false"
  • Reboot

This should force the Intel driver to stop VSyncing the DisplayLink monitor to 1fps.

Again I think I am not competent enough to assess the situation as to why this is an issue in the first place and so this workaround may break other stuff. So take everything here with care!

  • I just saw that Zanna reformatted my text a little (thanks I guess?), however, now the text for the 20-intel.confis written only in one single line. I am not sure how senstive xorg is to this stuff, but I think Zanna is more experienced than me ^^ – Znert Feb 21 '17 at 15:37
  • I added improved answer suggestion as a guest (guests can but I'm as a user cannot? weird....) If you need to know file formatting, it's in: /usr/share/doc/xserver-xorg-video-intel/xorg.conf that is, when you have xserver-xorg-video-intel installed on your system – janmyszkier Feb 27 '17 at 20:14
  • Note when doing this, you may think you've bricked your computer if it doesn't work. DO NOT PANIC. So, the solution is to let the system boot, the video driver will start bouncing in a loop (potentially), and press CTRL+ALT+F2. You'll see a login prompt. Login as your user account and then do "sudo su" to become root. Remove the file you just created. Then, reboot. You'll be back to normal again. – Volomike Jun 7 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.