2

I have unmet dependencies after a release upgrade very similar to:

Upgrade Ubuntu 16.04.1 from 14.04, no desktop appears

I ran:

wget http://launchpadlibrarian.net/259210936/libstdc++6_5.3.1-14ubuntu2.1_amd64.deb
sudo dpkg -i libstdc++6_5.3.1-14ubuntu2.1_amd64.deb

(At this point I used the i368 package that fits my chipset)

This is my error now:

>> sudo apt-get install
...
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libstdc++-5-dev : Hängt ab von: libstdc++6 (>= 5.4.1-2ubuntu1~14.04) aber 5.4.0-6ubuntu1~16.04.2 ist installiert
 libstdc++6 : Hängt ab von: gcc-5-base (= 5.4.0-6ubuntu1~16.04.2) aber 5.4.1-2ubuntu1~14.04 ist installiert
 libstdc++6-5-dbg : Hängt ab von: libstdc++6 (>= 5.4.1-2ubuntu1~14.04) aber 5.4.0-6ubuntu1~16.04.2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.

Can anyone help me to resolve these dependencies?

Update: I can't run apt-get -f install since this would delete my core system (including apt).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.