2

This recently began as of two days ago, Chrome will simply close randomly during regular usage.

I'm running chrome 54.0.2840.71 on Ubuntu 14.04.

This is running on my HTPC so during streaming on Netflix, youtube, philo, etc, chrome will simply close.

When I run from terminal to observe the output, chrome will hit a segfault and stop as a segfault will do. The only other output from the terminal are regular error calls referencing a failed call to 'freedesktop.Upower.GetDisplayDevice', saying "interface "org.freedesktop.Upower doesn't exist"

I attempted to remove with purge and reinstall from a fresh deb from the chrome site but the behavior has continued. I noticed I was still logged into chrome when I started it again so perhaps some configuration data wasn't fully removed.

Has anyone else been experiencing this change in behavior? Or possibly experienced it in the past?

Edit: happened again, here's the crash output:

--2016-10-22 22:40:58--  https://clients2.google.com/cr/report
Resolving clients2.google.com (clients2.google.com)... 216.58.219.238,   2607:f8b0:4006:80f::200e
Connecting to clients2.google.com   (clients2.google.com)|216.58.219.238|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘/dev/fd/3’

Crash dump id: f6446bab00000000
Segmentation fault (core dumped)

Edit 2: A friend brought up a point that this only started after installing Steam client to use in home streaming. Not sure if it could be related.

Edit 3: Just reinstalled the OS and upgraded to 16.04. Everything works now, sorry to anyone experiencing something similar but a clean install might be your best bet.

  • I'm having the same problem, I'm not using Steam though. I'd love to avoid a clean reinstall to fix this... – stbrody Oct 24 '16 at 19:29
  • I'm having the same problem on 16.10. Fresh install, haven't installed much of anything. :( – Joel Oct 27 '16 at 1:43
  • same symptom on my side, re-installed Chrome completely and still it randomly closes itself. Ubuntu 16.04 LTS Chrome 54.0.2840.71 (64-bit) – Raphael C Nov 2 '16 at 10:13
  • Try blocking ports 8008 and 8009. This worked for me. I guess this is related to Chrome searching for Chromecasts on the local network.Those are the ports it uses to discover Chromecasts. I easily blocked the ports with gufw (a gui firewall). More information can be found here: bugs.chromium.org/p/chromium/issues/detail?id=658106 – dave3 Nov 2 '16 at 20:15
  • As a follow-up, my reinstall will still have chrome crash from time to time, but now it seems like its running out of memory as opposed to a random segfault. – paumanok Nov 3 '16 at 15:11
0

I had similar issue and just upgraded to 54.0.2840.90 and it's been more than 2 hours, no more segmentation fault so far so good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.