1

I am running a fresh install of 16.04 Desktop 64-bit on a Gigabyte GA-C847N motherboard and the Realtek dual-ethernet card is not detected at all.

Running sudo lshw -c network shows the wireless interface (an Edmax USB wifi card installed to get online) but nothing else.

I have tried manually installing the drivers with sudo apt-get install r8168-dkms with no success.

Is there anything else I can try to see if the Ethernet card is actually working or if it might be fried?

Many thanks

Edit: output of lspci -nnk | grep 0200 -A2 is blank

alex@alex-itx:~$ sudo lspci -nnk | grep 0200 -A2

[sudo] password for alex:

alex@alex-itx:~$

Yes, both ports are enabled in BIOS - using Legacy and UEFI mode.

  • Please edit your question to add the result of the terminal command: lspci -nnk | grep 0200 -A2 Welcome to Ask Ubuntu. – chili555 Oct 23 '16 at 1:29
  • And is it enabled in UEFI? You probably checked it already but just in case... It wouldn't be the first time. – user589808 Oct 23 '16 at 1:58
  • Thanks for the feedback - post edited to reflect the answers. – Alex341 Oct 23 '16 at 9:13
  • I am beginning to think the 2 x Eth ports on the board are fried. Not uncommon here in Brazil. I am getting a cheap PCI 10/100/1000 to test next weekend. – Alex341 Oct 23 '16 at 13:45
0

There is a problem installing Ubuntu 64 bit on Gigabyte motherboards. Usb 2.0 and ethernet won't work. Try to install from USB 3.0 port. It worked for me. If not, go to BIOS and change UIMMO configuraton.

This problem is fixed on this thread. It works for (all?) Gigabyte motherboards:

https://ubuntuforums.org/showthread.php?t=2111223&page=4

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.