0

I've installed Ubuntu 16.04 on a machine that already had Windows 10 installed, I believe installed in UEFI mode. Upon installing Ubuntu I came across the option to disable secure boot, I didn't do so because I wasn't sure what it would do. After installation finished, the system just boots to Windows directly without showing the GRUB menu. Is there any solution to this?

I have a single partition dedicated to Windows that I shrinked, alongside the system and windows recovery partitions.

The laptop is an Acer.

6
  • 1
    Use your system's BIO's option to browse for Ubuntu for boot priority. Boot to the Ubuntu, then you will have an option in the Grub menu to select with OS you want to load. Oct 22 '16 at 19:23
  • 2
    Possible duplicate of Ubuntu missing from HP boot menu
    – Rod Smith
    Oct 22 '16 at 22:29
  • @RodSmith It's an Acer, not an HP, thus not even close to a duplicate.
    – Amine
    Oct 23 '16 at 11:16
  • @Amine the brand of the laptop is mostly irrelevant here. The problem and solution are almost identical. What you want to do though, as described, is to enter your BIOS (press del / F2 / F10 while booting), find the boot options, and see if there are multiple options. If so, you need to work out which one is the one you want. Also, don't worry too much about "secure boot", it's just a thing Microsoft invented to protect your PC from having other operating systems installed on it.
    – XtrmJosh
    Oct 23 '16 at 11:25
  • @XtrmJosh I tried to check the BIOS, it seems that I can't change to Legacy mode. I also read somewhere that I need to change the priority of boot in EFI mode? But how to do that is the problem, found several solutions with different approaches, I don't know which one is correct.
    – Amine
    Oct 23 '16 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.