1

I have a moto G4 and am trying to access files on it from my Ubuntu 16.04 system. If I simply connect it via usb I get a window pop up with MOTO G (4) on the top of the window. Hovering the cursor over the Moto G (4) on the sidebar tells me it sees it as mtp://[usb:001,006]/ However the file explorer is empty.

The properties in this window says

Name: Moto G (4)
Type: Folder (inode/directory)

Contents: nothing

Location:
Volume: mtp

I am able to connect over bluetooth, but the only option I have from the bluetooth toolbar is to send files. I might be able to send files by operating from my phone, but I'd like to be able to browse from my computer to decide what I want to pull.

Help that I've seen online has been mixed, and it seems like the proper methods have changed through the different ubuntu releases. I'm using 16.04 lts.

  • 1
    Have you tried turning on developer mode and enabled USB debugging? I had to do this to get it to work. – willem.hill Oct 22 '16 at 18:11
  • I just turned it on, no difference. – roro Oct 22 '16 at 18:12
2

Is your phone unlocked and in MTP mode?

The most common advice online for this problem is to connect, then pull down the notification bar, tap the USB Connection bubble, and change to MTP. In "Charge Only" mode, the phone connects via MTP but doesn't present any of its files.

A known issue with the G3 (which apparently affects the G4 as well) is also mentioned here, with identical symptoms:

This is a known issue with the Marshmallow update on G3 with SD card set as portable storage (users who switched to internal storage seem to have no issues)... Disconnect USB, then Go to Settings, Apps, and Show System Apps, then find External Storage and Media Storage, and clear data and cache on each one and reboot. Give it 5 min after full boot up to rebuild media databases and connect to USB and select MTP, should be good to go.

In addition, mounting via MTP sometimes takes ages for no apparent reason. I once gave up on troubleshooting this, leaving my phone connected while I worked on a different computer. When I returned an hour later it was magically working.

  • This was the issue. I tried pulling files from windows and had the same issue. Searching for the problem under windows I found people saying the same thing you did. Thanks. – roro Oct 22 '16 at 18:31
0

I just had the same issue with a Moto G3. I clicked on the USB notification, changed it from MTP to Charge only. Then I changed it back to MTP.

I opened it again in the file manager and the internal storage and SD card are both showing up again.

0

In case you have developer mode/options enabled, disconnect the USB cable, go to Developer Options from setting menu -> turn off USB debugging -> change Select USB Configuration to Charging -> close the Settings screen.
Then reconnect the USB, go back to Developer Options -> change Select USB Configuration back to MTP.
Hopefully, the files would be visible now.
Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.