1

On my laptop, the numpad keys stopped working when NumLock is ON. So I can input all the digits, but when I enable NumLock, the keys do nothing at all (directions, home, end, pgup/down, even Enter does nothing).

This happens when working from a terminal, or from gedit, etc. The "Keyboard Layout Chart" is showing that the keys I press are not received at all (when NumLock is ON).

The keys do work correctly when:

  • I create a simple terminal ("xterm" command)
  • I switch to one of the virtual terminals (Ctrl+Alt+F1)
  • In my browser.
  • I created a fresh user account, and logged in to it

I tried the usual things I found on the net:

  • "xev" utility shows that the keys are recognized correctly (I receive KP_Home, KP_Left, etc)
  • this is not related to "controlling mouse cursor with keypad" issue (I tried that option and I can fully enable/disable it in addition to my issue)

All that leads me to believe that some X-related input/keyboard filtering/processing configuration is to blame here, and that it's related to my account only.

Where else can I look to check what's wrong?

Are there any other files/configurations/tools I can check?

I had Ubuntu 15.10 when that happened (out of the blue, I didn't install/configure anything on that day), then I upgraded to 16.04 (hoping the issue would just go away). Reboots didn't help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.