6

This question already has an answer here:

After upgrading to Ubuntu 16.10 I am not able to use my laptop because of the high CPU Usage of "kidle_inject".

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                   
 7966 root     -51   0       0      0      0 S  35.2  0.0   4:27.77 kidle_inject/1            
 8327 xxxx      20   0 1906104 302952  69876 S  34.9  3.7   0:08.15 chromium-browse           
 7968 root     -51   0       0      0      0 S  34.5  0.0   4:31.28 kidle_inject/3            
 7965 root     -51   0       0      0      0 S  33.9  0.0   4:24.68 kidle_inject/0            
 7967 root     -51   0       0      0      0 S  32.6  0.0   4:28.50 kidle_inject/2            

sudo rmmod intel_powerclamp stops the crazy processes but I need to execute it each time after restarting my PC.

Please help me. Thanks.

marked as duplicate by user364819, WinEunuuchs2Unix, TheWanderer, Zanna, Eric Carvalho Nov 21 '16 at 13:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • any idea? it is so annoying :( – zappee Nov 3 '16 at 21:53
  • Happens to me often after system update and when it says a restart is necessary. A restart makes the kidle_inject proplem go away. For me at least. – Kjetil S. Aug 8 '18 at 10:36
3

You can make this permanent by making this be blacklisted on boot:

sudo echo "blacklist intel_powerclamp" > /etc/modprobe.d/disable-powerclamp.conf

However it should be noted that powerclamp is actually a feature which is there to prevent the processor from further overheating by limiting how much of the CPU can be used. So in fact those processes (1 for each CPU core) aren't using your CPU, but rather dictating how much of it should not be used.
Which is why things are slower.

Instead of disabling this feature, I would suggest that you make sure that your fan is working and that the inside of your computer and its vents are clean and not blocked up with dust etc. As this is a feature which comes on when your machine is already overheating, to try to prevent it from overheating any further. So in fact disabling it could cause your machine to overheat and your hardware could be damaged.

So I would highly advise that you make sure that your fan is working properly and that your machine isn't overheating before deciding to turn this feature off.

  • Yes. Make sure the fan is working is the better solution than disable intel_powerclamp. In my case, I just install macfanctld (fan control daemon for Ubuntu on macbook), and it works. For other brands, it is fancontrol package. – bagustris Apr 29 '17 at 8:43
  • For people that still are experiencing issues with this and have a MacBook check out this project: github.com/MikaelStrom/macfanctld it works way better than macfanctld (on my machine at least). – Dillen Meijboom May 9 '17 at 9:41
  • 1
    in my experience the powerclamp tool (1) starts too soon (at a lower cpu temp than I expect: I have a script to throttle down the CPU at given temp, but powerclamp starts before), and (2) while running it uses a lot of CPU and thus pushes the temperature UP (by contrast to the script I use anyway). Can the temp that triggers powerclamp be changed? – user47206 Oct 3 '17 at 11:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.