Disclaimer: I have tried the existing answers to various questions already. None of them worked.

Problem: When I Login to Ubuntu 14.04 via GUI, I'm redirected to the Login page again.


  • I'm able to Login via Terminal (using Alt+Ctrl+F1)
  • When I Login via GUI, I'm not getting any password mismatch errors. It just redirect me to Login screen again.
  • I'm able to Login as a Guest in via GUI.
  • Creating a new user and logging in under that one has the same problem.
  • /etc/lightdm/lightdm.conf is not found (only users.conf exist in /etc/lightdm/).
  • Under ~/.cache/, sessions is not there. (Identified while trying an answer from Ask Ubuntu)
  • linux-generic is up to date.

I changed the Login Password as per this. I'm getting this problem after that.

Things I tried:

  • Updating (sudo apt-get update)
  • Removing .Xauthority file.
  • Reinstalling lightdm.
  • Installing gdm instead of lightdm.
  • Reconfiguring the above lightdm.
  • Changing the ownership of .Xauthority.
  • Reinstalling Nvidia.
  • Purging and Reinstalling ubuntu-desktop.

When I tried reinstalling Nvidia, I got this enter image description here Kindly see more information about this here.

Please Help me out.

  • I have a similar issue – Jonathan Mar 23 '17 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.