0

i finally did the upgrade 2 days ago. i went to bed, woke up to no errors, and rebooted. unity got stuck in a login loop (unity 8 just freezes). after much trial and error (basically googling whatever answers i can find, throwing them at the wall, and seeing what sticks), i ended up w/ xubuntu installed (it "works," bunch of compiz crashes waiting to report once logged in), and that led to me switching to nouveau, so now unity "works" (i can't even remember what else was attempted). unity 8 still doesn't work (though that's not really a concern). this was fine on 15.10 (mostly - hello again, nomodeset) and 16.04 (completely). apparently, 304.132 is broken on all distributions. is there a way to force install 304.131 and ignore updates? the package from nvidia's site does not work at all (bombs out, won't even finish the install). nouveau would be fine, but something's not reading the EDID correctly (or at all, since 16.04 and 15.10 correctly identified my monitor down to the brand and model), so i'm stuck at 1280x1024 (sucks, should be 1680x1050). i dread the day i might fix my tv again and go back to the dual-monitor setup. video card is a geforce 7800 gt, so other major versions are not an option, nor is buying a different video card.

over the last 48 hours, i've become quite adept at getting back to this point, so whatever needs to be broken to diagnose the problem, i'm ok w/ it. i already know the current driver is trash, so i guess i'd really just like to force the old driver on here if possible. if not, i'd be ok w/ nouveau running the right resolution (the xrandr route definitely does not work).

thank you for your consideration.

9
  • -1? how can somebody vote down an initial question? was it not questiony enough for you? if i already had a solution, i wouldn't be asking. this stupid point system that requires me to ask a question before i can comment on other posts where i might have something useful to offer probably ought to at least require some comment detailing why someone thought this wasn't questiony enough.
    – rngwrm
    Oct 22, 2016 at 10:47
  • The question was voted as unclear and I agree, it is mostly a rant and has far to much superfluous info. Your comment is a bit rude and will make people not want to help, however, here is something to try. Remove any nviodia drivers sudo apt purge nvidia* then add this PPA sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt update then sudo apt install nvidia-304
    – Mark Kirby
    Oct 22, 2016 at 11:03
  • thank you, those are both already done. purging nvidia breaks everything. have to start all over, boot to recovery, go to shell, reinstall nvidia-current, reboot, log in to xubuntu, switch back to nouveau, reboot again, and i end up right back here.
    – rngwrm
    Oct 22, 2016 at 11:15
  • Don't install nvidia-current it is depreciated, go to recovery and enter the commands I gave you after removing any old nvidia drivers. Note that the command is nvidia-304 not nvidia-current these are not the same .
    – Mark Kirby
    Oct 22, 2016 at 11:17
  • i'm doing it, but i'm pretty sure nvidia-current just installs nvidia-304. to wit: The following packages will be REMOVED: nvidia-304* nvidia-opencl-icd-304* nvidia-settings*
    – rngwrm
    Oct 22, 2016 at 11:33

2 Answers 2

2

I managed to work around this by forcing the version 304.131-0ubuntu3 from the terminal by:

  1. Double check the versions that are available with sudo apt-cache showpkg nvidia-304
  2. Remove current version just to be safe sudo apt-get remove nvidia-304
  3. Force the previous version via sudo apt-get install nvidia-304=304.131-0ubuntu3
  4. Hold the package from automatically updating apt-mark hold nvidia-304
  5. Reboot and hope it ends up working
0

I manage this issue in this way:

  1. Run Synaptic Packet Manager
  2. Select the packet named: nvidia-304
  3. Go to menu Package | Force version...
  4. Select: 304.131-0ubuntu3 (xenial)

then do the same for nvidia-opencl-icd-304

It is working for me.

1
  • i'd meant to come back and edit question for clarity / sobriety, but i forgot about it, and once 304.134 came out, everything worked again. 304.135 just broke it again, so i found this same answer at howtogeek.com/117929/how-to-downgrade-packages-on-ubuntu. this is the correct answer, and thank you very much.
    – rngwrm
    Feb 16, 2017 at 21:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.