I am using Ubuntu 16.04. I am a new user want to learn terminal. I prefer using the terminal instead of Software Center. I tried several times to install vlc by using both:

$ sudo apt-get update    
$ sudo apt-get install vlc browser-plugin-vlc


$ sudo apt-get update    
$ sudo apt-get install vlc browser-plugin-vlc

But this message appears every time:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 3.0.0~~git20160525+r64784+62~ubuntu16.10.1) but 2.2.4-4 is to be installed
E: Unable to correct problems, you have held broken packages.

So, at last against my will I went to Software Center. However, to install vlc I had to log in at Ubuntu One. I tried to log in, but I can't. It said invalid email/password.

So, tell me what can I do, please?

  • Please edit your question and add the outputs of apt policy vlc vlc-nox and grep -r --include "*.list" "^deb" /etc/apt/sources.list*. You have a version conflict because you probably have an unofficial software source added that provides newer versions of vlc, but not its dependency vlc-nox.
    – Byte Commander
    Oct 21, 2016 at 21:01
  • 1
    He's got a vlc from the vlc master ppa for 16.10 built on 05/25 & probably isn't using 16.04 as 2.2.4-4 is the ubuntu repo vlc version for 16.10. (or has mixed in 16.10 repos on a 16.04 install
    – doug
    Oct 21, 2016 at 22:37

1 Answer 1


Short answer: You're trying to install vlc in version 3.0.0, but the vlc package depends on vlc-nox (and maybe others). apt can't find a vlc-nox package in version 3.0.0 in the repositories you configured, only one in version 2.2.4. Also, you're trying to install a vlc package meant for Ubuntu 16.10 on Ubuntu 16.04, which may cause problems.

Long answer: Packages can depend on other packages. To install vlc, you need to install vlc-nox (VLC to use without a graphical interface, "no X") as well in a corresponding version. If you, for example, want to install vlc in version 2.2.0, you need vlc-nox in version 2.2.0.

apt tries to install the latest version of a package it can get from the repositories you have configured. In your case, that is vlc 3.0.0~~git20160525+r64784+62~ubuntu16.10.1. So you would need a 3.0.0 version of vlc-nox as well. But the latest version of vlc-nox that's available from your repositories is 2.2.4-4.

Also, the 3.0.0~~git20160525+r64784+62~ubuntu16.10.1 version is meant for Ubuntu 16.10, not Ubuntu 16.04. It's always a gamble to use packages that were build for different Ubuntu versions. It may work, it may not work.

So you need to check the repositories you have installed. There might be a repository that's meant for a later Ubuntu version and doesn't work on your version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .