0

Ingredients

  • Laptop Acer Aspire V11 Touch
  • Ubuntu 16.04 (kernel 4.4.0-45)
  • Additional driver 'Broadcom 802.11 Linux STA wireless device' in use
  • lspci -knn | grep Net -A2

    02:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01) Subsystem: Foxconn International, Inc. BCM43142 802.11b/g/n [105b:e07e] Kernel modules: bcma, wl

  • rfkill list

    0: acer-wireless: Wireless LAN Soft blocked: no Hard blocked: no 1: acer-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 2: hci0: Bluetooth Soft blocked: no Hard blocked: no

Issue

I cannot see any option to enable the wireless device from the applet main menu bar. As a result I cannot activate and use the wi-fi.

Research

I am almost-fully aware of this extensive post on Installing Broadcom Wireless Drivers, but installation is not the point. However, I have followed the uninstall/install sequence:

sudo apt-get purge bcmwl-kernel-source
sudo apt update
sudo update pciids
sudo apt install firmware-b43-install
sudo reboot
sudo apt install bcmwl-kernel-source # corresponds to my PCI id 14e4:4365 (rev 01)
sudo rfkill unblock all # for good measure

to no avail. Note that at sudo apt install bcmwl-kernel-source a dialogue window asks permission to disable Secure Boot by typing an ad hoc password. It claims it will be asked later, although I did not see it being asked again.

Interestingly, from this bounty-winning answer https://askubuntu.com/a/199154/446253, I could see with lspci -nn | grep -i BCM that my network controller is a BCM43142 that might not be supported by the STA driver. This is way too esoteric for me, but it may provide a clue to the expert.

I am also aware of other posts that deal with earlier Ubuntu versions, but I would dearly avoid guesswork and find an answer that applies to 16.04 safely.

Question

Please could you provide a list of simple steps to regain the possibility to enable the wifi from the menu bar?

If you need to refer to verbose posts, please indicate which answer is applicable according to you and in which way it integrates the actions undertaken above.

6
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A2; rfkill list terminal command.
    – Pilot6
    Oct 21, 2016 at 14:34
  • @Pilot6 Info added in ingredients list Oct 21, 2016 at 15:16
  • Disable Secure Boot in BIOS.
    – Pilot6
    Oct 21, 2016 at 15:17
  • @Pilot6 Please convert comment into answer, it works. If the question shows research effort, is useful and clear please considering upvoting the post. Oct 21, 2016 at 15:26
  • I answered this a few times already, you can find duplicates.
    – Pilot6
    Oct 21, 2016 at 15:36

2 Answers 2

0

In my experience the problem comes up for either of two reasons, or both:

  1. secure boot in the boot set-up utility is enabled. It should be disabled instead. Thanks to user Pilot6 for pointing this out in the comments above.

  2. a new kernel does not cope well with the network and wi-fi settings. In my case the solution 1 works with kernel 3.19.0-77-generic or 4.4.0-45-generic, but not with the later 4.4.0-53-generic. To splash into an older reliable kernel, at boot time I go into the 'Advanced Ubuntu Options' of the boot loader rather than using the standard 'Ubuntu'. I am presented with this choice at restart since I have a dual boot system: if you don't, you can press the shift key at boot time to have this choice presented to you. See https://askubuntu.com/a/885850/446253 for a way to select an earlier kernel version as boot-time default automatically, using Grub Customizer.

To know which kernel the system is running on type uname -r in the command line (the output is a subset of uname -a).

This problem occurred with both Ubuntu 14.04 and 16.04. I then presume that the release specification is immaterial.

-1

You need to install the 4.8 kernel and firmware. Run these 3 commands in a terminal:-

sudo apt install linux-generic-hwe-16.04-edge
wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161.1_all.deb
sudo dpkg -i linux-firmware_1.161.1_all.deb

Reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.