1

I've checked each and every option and possible solutions but my ASUS laptop doesn't suspend when I close the lid. All settings were set proper via the menues but nothing happens. When I perform a suspend from ubuntu menu it works perfect. Ok, I had to add a "network-manager restart" because of disabled Wifi but in the end suspend and resume in general works.

I have tested the scripts from the other posts and in addition uncommented the "HandleLidSwitch(Docked)" events to suspend but it didn't help. Tried everything below With Ubuntu 16.04 laptop doesn't suspend when lid is closed but nothing worked for me.

I was able to check with external monitor that the lid switch in general works. I checked /proc/acpi/button/lid/LID/state and found "closed" or "opened" correctly.

In log of journalctl I can see that systemd-logind is "watching system buttons for LID"

Here is the relevant text:

Okt 21 15:35:28 Dijana-ASUS systemd-logind[643]: Watching system buttons on /dev/input/event0 (Lid Switch)

A different laptop with same 16.04 LTS shows the same entry in journalctl but there suspend on lid works and the lid close event is recognized by systemd-logind.

Is this a bug or is my laptop simply too stupid? On a different partition I have tested the old 14.04.5 (with latest kernel) and I have the same misbehaviour...

Can anyone help?

Regards, Dijana

Additional information... ASUS F453S with Intel® Celeron(R) CPU N3050 @ 1.60GHz × 2

Ubuntu shows Intel® HD Graphics (Cherryview)

lspci | grep VGA shows 00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 21)

  • Please edit and add the exact model and also hardware specs. It may be related with graphics drivers or others. – user589808 Oct 21 '16 at 14:28
  • To circumvent the same problem I wrote a script to intercept lid close. Then later I upgraded Kernel and stopped using script. – WinEunuuchs2Unix Oct 21 '16 at 14:54
  • Updated technical information... @WinEunuuch2Unix: Do you have more info about this script? – Dijana Markovic Oct 21 '16 at 18:09
1

So in the end I gave up and did it via workaround script. Just created a script like this and put it to root crontab for executing every 5 minutes. Not nice but it works and in the end it's only for those cases that our child closes the lid. Here is the content of the script:

#!/bin/bash
if grep -q closed /proc/acpi/button/lid/*/state

then
     /usr/sbin/pm-suspend
 fi
  • You can mark your own answer as accepted by clicking the gray check mark beside the answer to change its color to green. – karel Oct 27 '16 at 14:35
1

I fixed with using acpid with the following solution

sudo gedit /etc/acpi/events/lidclose

copy, paste & save

event=button[ /]lid
action=/etc/acpi/lidclose.sh

execute

sudo gedit /etc/acpi/lidclose.sh

copy, paste & save

#!/bin/bash
echo "close" > /home/jesse/close.txt
if grep -q closed /proc/acpi/button/lid/*/state

then
     /usr/sbin/pm-suspend
fi

execute

sudo chmod ugo+x /etc/acpi/lidclose.sh

restart acpi service or reboot

  • Didn't work for me (Asus N550JV). – Sebastian Nov 18 '17 at 15:06
  • Don't forget to install pm-utils first. – Claudio Taccogna May 1 '18 at 15:39
0

Upgrading to the 4.9-rc1 kernel fixed the problem on my Asus. Different model (X540SA) but had the same issue. The change-log contained several ACPI and power management fixes.

  • power management updates
  • ACPI updates
  • PNP update
  • more power management updates
  • more ACPI updates

4.9-rc2 was just released with similar changes but I can not confirm that it also resolved the issue.

Also, have you checked your BIOS settings for waking on lid opening? Hate to ask but I know some AMI BIOS versions can be confusing.

  • I will try the newest kernel. Tried one 4.6.-Kernel and I got after a couple of minutes always GPU problems. Unity was completely frozen so I switched back to kernel 4.4.21 – Dijana Markovic Oct 25 '16 at 9:38
  • BIOS setting I didn't check but when I manually suspend and close the lid then my laptop resumes when opening lid again. – Dijana Markovic Oct 25 '16 at 9:39
  • The 4.6-4.8 kernels either didn't fix the issue or made GPU issues even worse for me too. I was really surprised to find that 4.9 changed everything. Also, sounds like BIOS settings are not the culprit. @DijanaMarkovic – CabledAliens Oct 25 '16 at 16:07
  • Tried kernel 4.9-RC1 and system hung up after showing terminal messages regarding "probably missing firmware i915"... I had to remove this kernel so problem still open. BIOS setting is proper. – Dijana Markovic Oct 25 '16 at 18:46
  • I did a reinstall of Linux Mint on another partition and received the same message. Have you opened driver settings and enabled the intel microcode proprietary drivers for your machine? I enabled them and then attempted to reinstall 4.9 and it worked perfectly. Did not spit "probably missing..." error @DijanaMarkovic – CabledAliens Oct 27 '16 at 22:41

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.