I am dual booting Windows 10 and Ubuntu 16.04 in my Acer E5-575G-53VG.

I'm facing this issue where the internet through the wifi drops randomly for 2 - 3 minutes while on Ubuntu. The wifi signal is always full and connected but the internet in my browser says no internet. Now this works perfectly on Windows and there are no drops at all which leads me to believe this is a driver issue.

lscpi Output -

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers
        (rev 08) 00:02.0 VGA compatible controller: Intel Corporation Sky Lake
        Integrated Graphics (rev 07) 
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0
        xHCI Controller (rev 21) 
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP
        Thermal subsystem (rev 21) 
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP
        Serial IO I2C Controller (rev 21) 
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP
        CSME HECI (rev 21) 
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller 
        [AHCI mode] (rev 21) 
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1) 
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1) 
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1) 
00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1) 
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21) 
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21) 
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21) 
01:00.0 3D controller: NVIDIA Corporation Device 179c (rev a2) 
03:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 31) 
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01) 
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd.
        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

What could be the problem and how do I solve it?

EDIT -

NW Diagnostics during outage - http://paste.ubuntu.com/23358150/

NW Outage after outage - http://paste.ubuntu.com/23358156/

  • I have added the network diagnostics – siddharth185 Oct 21 '16 at 9:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.