I have a GTX 950 connected to a huge monitor, and my motherboard's VGA is connected to 18" Dell...which displays things fine during boot (and in Windows), but by the time I hit the Ubuntu splash screen, it is just a blank console-like screen with only an underscore displayed in the top left. The other (main) monitor works fine. NVIDIA binary driver 361.42

I've failed to detect display in settings and in Nvidia's XServer program to. I have tried rebooting and th elike

Really could use some help, would hate to have to resort back to Windows


Not sure if it'd be helpful but worth a try

First list detected monitors using

xrandr --current

This will show connected display devices. Mine shows something like this

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
LVDS-1 connected
   1366x768      60.10 +
   1360x768      59.80    59.96  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
VGA-1 connected primary 1920x1080+0+0 477mm x 268mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1280x960      60.00  
   1280x720      60.00  
   1024x768      75.08    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00  
   720x400       70.08  
HDMI-1 disconnected
DP-1 disconnected

If both of your monitor is shown as connected then you can push the output as

xrandr --output VGA1 --auto --right-of LVDS1

where VGA-1 is the monitor you want to set the output to and LVDS-1 is the monitor which is currently working

In case of multiple source providers (i.e motherboard and discrete graphics card) use following to list out the providers:

xrandr --listproviders

Which may output something like

Providers: number : 3
Provider 0: id: 0x2cd cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x46 cap: 0x2, Sink Output crtcs: 3 outputs: 4 associated providers: 1 name:modesetting
Provider 2: id: 0x46 cap: 0x2, Sink Output crtcs: 3 outputs: 4 associated providers: 1 name:modesetting

In the above output, provider 1 & 2 are the DisplayLink device, and provider 0 is the default display. You need to offload DisplayLink to the main GPU as:

xrandr --setprovideroutputsource 1 0
xrandr --setprovideroutputsource 2 0

Now you can check again for available displays and set output to them

  • 1
    so xrandr is showing me all the ports on my GPU, and my VGA is from the mobo. How do I tell Linux to use a mobo's display port as well? – kelemeno Oct 21 '16 at 6:26
  • @kelemeno check the edit – Frozen Helium Oct 21 '16 at 8:52
  • Thanks so far for your help. I am getting closer. If I offload VGA to GPU, my Display Settings indeed recognize the second display. The second display is "Unknown Display." When I enabled it (using the Ubuntu GUI), I got terrible resolution on my main monitor and it was just funky interaction (but the second monitor displayed!!!) So I restarted, changed output source again, and tried – kelemeno Oct 21 '16 at 23:16
  • I tried 'xrandr --output VGA1 --auto --right-of HDMI-0' and got basically the same results. Since then I've experimented with different Display Setting options and now I can't get the second monitor to display anything at all, and whenever I enable it, the main monitor's resolution goes terrible. – kelemeno Oct 21 '16 at 23:17
  • I've now also tried using xrandr to add another resolution to the VGA (1280x1024) but that hasn't helped. – kelemeno Oct 22 '16 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.