0

I've seen some similar questions on here, but nothing that quite matches my exact problem. I will try to be as concise as I can while providing all the details:

I installed a new MAAS server on bare metal following the instructions here: http://maas.io/get-started

The MAAS server has 2 interfaces set up. the first is on a public vlan inside my lab and the second is on a private vlan inside the same lab.

I have two additional machines (for testing) that only have 1 interface each which is setup on the private vlan as well.

After completing the MAAS server setup, I rebooted (PXE) one of the other machines. immediately I saw the "Booting under MAAS direction..." screen followed by a bunch of activety. then I see some cloud-init activety:

cloud-init

followed by some more cloud-init activety which seems to be throwing errors around "instance_id"

cloud-init errors

finally, the machine stops at an ubuntu login screen.

My problem is that this machine never seems to "enlist" or show up in the MAAS server even though it received the initial DHCP response from MAAS. so I have no information about it, what the IP address is or anything like that to be able to log into it.

Any help would be greatly appreciated! Thanks!

UPDATE

I updated the default gateway of the subnet to be the private IP address of the maas server. this resulted in a slightly new behavior during cloud-init: cloud-init-new

as you can see, it's now getting a 404 from http:///latest/meta-data/instance_id URL.

Thanks in advance.

  • Do you have a gateway set for your private vlan? – user508889 Oct 20 '16 at 22:12
  • No, there is no gateway for the private vlan. I didn't think this would be needed since traffic doesn't leave the private network. – spencerwjensen Oct 20 '16 at 22:15
  • Set it to the private vlan ip of the maas server and give it a whirl. I had a similar issue before. – user508889 Oct 20 '16 at 22:42
  • @bc2946088 are you referring to the gateway setting under the subnet settings on the maas server? – spencerwjensen Oct 20 '16 at 23:38
  • @bc2946088 I set the gateway as you suggested to the private IP of the maas server. I do get a slightly different behavior during cloud-init: Calling 'http://<private_ip>/latest/meta-data/instance_id' failed: bad status code [404] any thoughts? – spencerwjensen Oct 21 '16 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.