1

I'm still very new to Ubuntu, and I have it running on two computers. On the first computer, I was able to install and run steam no problem. I'm running Ubuntu 16.04 on both of them. Steam is installed on the other one, steam will install in the Ubuntu Software program, but when I try to run it, the icon will flash on the sidebar for about 15 seconds, then disappear. Steam will still appear in the system monitor. I have been killing the process before I try to restart steam with other methods.

I tried uninstalling and reinstalling and restarting my computer.

I tried running this code from here to see if that would fix it (it didn't.)

rm ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6

I was able to get it to launch using this

 LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam

from this website.

and also this

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

from here

It runs, but when I restart it I have to use the same code again, it will not launch from the icon in the menu.

I followed the directions from here to try to change the desktop to automatically do the command line but it did not work. I changed the line to

bash -c "LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam" 

and that seemed to work for the icon in the computer menu.

I think there should be a better way to do this, and if there is, I would dearly like to know. Is there a better way to do this? Is this a reasonable and acceptable solution, will this harm my computer in any way? I am also new to this site, this is only my second question I've ever asked, so if this question is in some way inappropriate, please be nice and let me know.

When I type steam in the terminal, I get the following:

Running Steam on ubuntu 16.04 64-bit
STEAM_RUNTIME is enabled automatically
/bin/bash: /home/banannakat/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash) 
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
awk: /home/banannakat/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /lib/x86_64-linux-gnu/libreadline.so.6)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
Installing breakpad exception handler for appid(steam)/version(1476379980)
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
3
  • 1
    Could you give us the output when you run steam from command line? Just type steam in the command line. – Marton Oct 20 '16 at 20:54
  • IMHO the question is fine, but it appears that you already have a solution that works. You might edit the working solution out of your question and place it in an answer so that those with the same problem can find it. If it works for them as well you're likely to gain some rep from it. NO, your solution doesn't look dangerous to me. – Elder Geek Oct 20 '16 at 21:02
  • I have added the output. If this is really the only solution, I'll add my answer to this post. Thanks! – Turtle Oct 20 '16 at 21:03

Browse other questions tagged or ask your own question.