8

I have:

mona@pascal:~$ cat /etc/default/sysstat
#
# Default settings for /etc/init.d/sysstat, /etc/cron.d/sysstat
# and /etc/cron.daily/sysstat files
#

# Should sadc collect system activity informations? Valid values
# are "true" and "false". Please do not put other values, they
# will be overwritten by debconf!
ENABLED="true"

and then:

mona@pascal:~$ sudo sar -d
Cannot open /var/log/sysstat/sa20: No such file or directory
Please check if data collecting is enabled in /etc/default/sysstat

Can you please suggest a fix?

Ubuntu 14.04
  • 1
    Did you run sudo service sysstat start afterwards? – heemayl Oct 27 '16 at 23:09
20

Open /etc/default/sysstat using your favorite file editor and change ENABLED="false" to ENABLED="true"

vi /etc/default/sysstat
----
# Should sadc collect system activity informations? Valid values
# are "true" and "false". Please do not put other values, they
# will be overwritten by debconf!
ENABLED="true"
----

Restart sysstat: sudo service sysstat restart

and now here you are!

| improve this answer | |
  • 5
    o.m.g....... why would it not be enabled by default? Now that I need it that history, I find that it hasn't been collecting it for me. Past CPU and memory usage has been lost to the wind. Argh. – Todd Walton Jul 5 '18 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.