2

I am using an tower pc with an Ati RX 480, which worked fine with the proprietary driver including the sound via HDMI on the screen using Ubuntu 16.04. After I upgraded to Ubuntu 16.10, sound stopped working. Furthermore the fonts and the ubuntu logo during the boot process are displayed wrong on my big screen (3440 x 1440), while my other screen (FullHD) has normal fonts and the normal logo.

Sound via the normal sound output is working.

The troubleshooting from https://help.ubuntu.com/community/SoundTroubleshootingProcedure unfortunately did not help: Deleting .config/pulse, stopping pulseaudio and so on did not change anything. The diagnostic command from step 4 returned https://nopaste.me/view/671d3225 Muting and umuting the S/PDIF, S/PDIF 1, ... and S/PDIF 5 did not change anything. There are no bars displayed in alsamixer for the hdmi audio card, only the S/PDIF-entries with 00 or MM - may this be a problem?

Is there any known bug for this, or a workaround? I tried to reinstall the proprietary driver, but this returned the following output:

dagere@dagere-desktop:~/Downloads/amdgpu-pro-driver$ ./amdgpu-pro-install 
tee: /etc/aptsources.list.d/amdgpu-pro.list: Datei oder Verzeichnis nicht gefunden
deb file:/var/opt/amdgpu-pro/ ./

Only /etc/apt/sources.list.d/amdgpu-pro.list is existing, is it safe to just change the directoy in the install-script?

Has anyone experience with getting hdmi-sound working with the opensource-driver delivered with ubuntu 16.10 or with getting the proprietary driver installed in ubuntu 16.10?

EDIT While the newest amd-driver is installable on ubuntu 16.10, this does not solve the sound issue. Furthermore, even if I install the 4.9.11, as far as I see the newest kernel (like described in How to update kernel to the latest mainline version without any Distro-upgrade? with dpkg -i *.deb), sound stays unusable.

EDIT 2 Since in 16.04 sound was working correctly, I tried installing it in parallel. In 16.04, eclipse scrolling is slow (and requires much CPU), which imho seems like the driver is not working correctly. I found https://community.amd.com/thread/203889 which recommends MESA-update, linux-firmeware update and kernel-update from Ubuntu 16.04. I tried this one, but with any kernel (4.4.0.62, 4.9.11-040911 and 4.10.0-041000) the problem in eclipse is still appearing. Nevertheless, with a newer kernel the sound stops working. So now with 16.04, sound works and eclipse not, and with 16.10, eclipse works, but sound not. (Setting --launcher.GTK_version 2 in eclipse does not change anything). Is there any workaround for this, either to get the sound working in 16.10 or the graphics working in 16.04?

EDIT 3 Still not working in Ubuntu 17.04 with Kernel 4.10. I'd still be glad about other suggestions.

1

Did you check out the kernel recommended here? https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-AMDGPU-DC-Kernel

I had no audio over HDMI on with my RX 480 on ubuntu 16+. After installing this kernel with AMDGPU DC/DAL support it all worked perfectly.

1
  • Thanks for the hint! I tried kernel 4.13.2-041302.201709132057 and some older kernels, none of this did it, but the kernel linux-image-4.12.14+ from github.com/M-Bab/linux-kernel-amdgpu-binaries did it - now both my sound and my graphics are working fine. I hope this will be merged into 4.14. Sep 28 '17 at 17:57
0

Just did an update to 16.10 and had this same issue. After poking around a bit, did a driver update from AMD's website and all is right as rain now. You can find directions here: http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

2
  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Feb 3 '17 at 3:22
  • The newest version of the driver (16.60) is also installable on Ubuntu 16.10, thanks for the hint. Unfortunately, this does not solve the sound-issue for me. Feb 20 '17 at 10:27
0

Unfortunately, this is not an configuration issue but a problem of the current kernel. The original drivers for RX 480 and other systems will merged into kernel at 4.15, with lower kernels, some features do not work, e.g. sound. My current workaround is to use the AMD proprietary kernel from https://github.com/M-Bab/linux-kernel-amdgpu-binaries . It can be installed via:

cd /tmp
git --git-dir=/dev/null clone --depth=1 https://github.com/M-Bab/linux-kernel-amdgpu-binaries
cd linux-kernel-amdgpu-binaries
sudo dpkg -i *.deb

(To use the kernel, reboot and eventually choose it in grub).

Fortunately, ubuntu 18.04 will ship with 4.15 kernel (https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-18.04-LTS-Linux-4.15), so hopefully this will fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.