I cant seem to be able to adjust the brightness on my think-pad laptop running Ubuntu 10.04. In the power management applet it shows that the power is set to 100%, but even if i try to lower it the actual screen brightness dosent change.

Any ideas of how I can get around this?

I tried changing the brightness from the terminal but its already set to Max brightness (however the actual screen brightness is no that bright at all).


2 Answers 2


oh,I've met this problem before.All you need to do is:

sudo gedit /etc/X11/xorg.conf

find segment like this:

Section "Device"
Identifier    "Default Device"
Driver    "nvidia"
Option    "NoLogo"    "True"

change it like this

Section "Device"
Identifier    "Default Device"
Driver    "nvidia"
Option    "NoLogo"    "True"
Option "RegistryDwords" "EnableBrightnessControl=1"

JUST ADD THIS LINE: Option "RegistryDwords" "EnableBrightnessControl=1" !

Then restart,It will work.

  • Where do i place this line? I tried putting it at the end of the file, and when I restart the laptop is just crashes on boot up (just freezes on the linux load screen).
    – Mo.
    Nov 30, 2011 at 12:19
  • lol!Sorry for that,I forgot to tell you that you should add this line in the Section "Device" .I'll edit my answer.Sorry for that Nov 30, 2011 at 12:38
  • This helped me as well on Ubuntu 12.04 LTS. Thank you! May 9, 2012 at 15:39

I was able to get my brightness keys working on my Lenovo W530 on Ubuntu 12.04 (posting here to help people looking for answer in future)...

These days X automatically configures itself, so you can't just edit the xorg.conf file, you, instead need to add a section to a file in /usr/share/X11/xorg.conf.d/ and X will include that section in the configuration that it automatically generates.

So to get the screen brightness keys working with your Nvidia graphics card, create a file in the xorg.conf.d directory, e.g:

sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf

Paste the following into the file:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"

Log out and log back in, or reboot, and your brightness keys should now work!

(I blogged this here)

  • I also have a Lenovo W530 on Xubuntu 13.10 and had this same problem. This answer is the only thing that fixed it.
    – OSE
    Oct 26, 2013 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.