I have installed Windows 7 and Ubuntu 16 and I can see both on the bootloader, however I can only start Ubuntu. If I choose Windows in the bootloader it shows an error message and then reboots the computer. It seems like the Windows link is broken on the bootloader.

$ sudo fdisk -l
Device     Boot        Start        End    Sectors   Size Id Type
/dev/sda1               2048   97656344   97654297  46.6G 83 Linux
/dev/sda2  *        97656832 1949212671 1851555840 882.9G  7 HPFS/NTFS/exFAT
/dev/sda3         1949214718 1953523711    4308994   2.1G  5 Extended
/dev/sda5         1949214720 1953523711    4308992   2.1G 83 Linux  

Device         Start       End   Sectors  Size Type
/dev/sdb1       2048    206847    204800  100M EFI System
/dev/sdb2     206848    468991    262144  128M Microsoft reserved
/dev/sdb3     468992 151764991 151296000 72.1G Microsoft basic data
/dev/sdb4  243890176 250068991   6178816    3G Linux swap
/dev/sdb5  151764992 243890175  92125184   44G Linux filesystem

It seems like the init is sda2 which is the partition with my Windows data, however the Windows OS is in sdb3.

The Boot Repair Boot Info Script generated these results.

I have installed boot-repair, but it says that it does not work in Legacy Mode, only in UEFI.

Also I have added these lines in /etc/grub.d/40_custom and updated grub, however these entries do not let me boot Windows 7 either:

menuentry "Windows 7aa (loader) (on /dev/sdb1)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
chainloader +1
menuentry "Windows 7bb (loader) (on /dev/sdb3)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos3)'
chainloader +1

What else can I try?

Also I have tried

sudo update-grub and sudo update-grub2


Windows entries in grub show me this error "The partition does not exist, press any button to continue..." and then again the grub menu appears. I have tried adding a new Windows entry for the Microsoft reserved partition /dev/sdb2 (hd1/msdos2) and it shows a different screen:
Boot loader Windows administrator, choose a O.S. only with Windows option, if I choose it, then the computer reboot.

  • Why do you have Windows 7 installed in EFI mode? EFI dual-booting always causes problems. – You'reAGitForNotUsingGit Oct 20 '16 at 11:46
  • “Windows is installed in the MBR of /dev/sdb.” Have you tried to select your /dev/sdb in BIOS boot menu? BTW are you using Ubuntu 16.04, or 16.10? They are not the same. – Melebius Oct 20 '16 at 11:52
  • You cannot use grub to dual boot if systems are not both UEFI or both BIOS boot. You can dual boot only from UEFI menu and may have to turn on/off UEFI or BIOS mode to match install. Some auto switch using entries in UEFI boot menu. Since Windows is UEFI, probably better to install Ubuntu in UEFI boot mode on sda. Repartitioning to gpt may erase all data on sda, so have good backups. help.ubuntu.com/community/UEFI and: askubuntu.com/questions/743095/… – oldfred Oct 20 '16 at 16:48

Try mount to set root='(hd1,msdos2)' --> sdb2 or Microsoft Reserved, on my hackintosh i can run my windows only from Microsoft Reserved (Clover Bootloader).

  • I have tried your suggestion, is not working for me. I have updated the post with the results. Thanks anyway :) – marilia15 Oct 21 '16 at 8:23

Finally I solved the problem using a USB with Boot-repair.

All the comments suggest the problem was my Windows installed in UEFI and Ubuntu 16.04 in BIOS. Changing options in BIOS did not solve the problem. Then I try to convert Ubuntu to UEFI mode, but tutorials says I need to run Boot-repair. Boot-repair was installed in Ubuntu but it did not work because Ubuntu was running in Legacy mode instead of EFI. Then I create a USB with Boot-repair and after 2hours with the "recommended fix" it finally works.

Now GRUB is installed in UEFI and I do not have two menus as before. Grub had 8 new entries for Windows, but only 1 works so I did delete the other editing the file /etc/grub.d/25_custom.

Thank you very much for your quick help, attention and suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.