2

[I already had this problem on Xubuntu 16.04, solved by upgrading the kernel]

Recently, I installed Xubuntu 16.10 on my Acer Aspire E1-570G. It wasn't going to suspend when I close the lid, so I used a little trick by uncommenting HandleLidSwitchDocked=suspend on /etc/systemd/logind.conf and the device suspends when I close the lid, but when I open the lid, I just see a command line cursor blinking and after a few seconds it stops blinking and nothing more comes out, have to restart it by holding ALT+PRT SC and typing REISUB. I've tried this with Kernel v4.8.0 and v4.8.1

What should I do to fix this problem?

Update: I have the same problem with suspending the device from login menu and physical suspend key. When I suspend the device, there won't be waking up X(

8
  • In 'System Settings', 'Power' do you also have it set to 'Suspend' on lid close? Some times it needs to be set in both places. Oct 20 '16 at 11:48
  • @WinEunuuchs2Unix Yes, I have.
    – Ehsaan
    Oct 20 '16 at 12:45
  • You set the 'docked' but did you set same variable name without docked a couple of lines up as well? Oct 20 '16 at 14:52
  • @WinEunuuchs2Unix No I didn't, here is my complete conf file: paste.ubuntu.com/23354146
    – Ehsaan
    Oct 20 '16 at 15:30
  • Reboot after a failed resume and type gedit /var/log/syslog and scroll to the time of suspend and resume and look for error messages to shed light on what driver(s) or applications might be freezing system. Oct 21 '16 at 10:51
2

From your file /etc/systemd/logind.conf we see these lines:

#HandleLidSwitch=suspend
HandleLidSwitchDocked=suspend

On the first line you need to remove the #, save the file and reboot.

You removed the # from the second line which suspends the laptop when it is docked ie. plugged into a docking station or when there is a secondary HDMI monitor / TV plugged in.

The first line controls suspending when the laptop is not docked.

For others reading this answer keep in mind from the Launcher select System Settings and click the Power applet and make sure it is also be configured like this:

Power Suspend

Notice the When lid is closed section. Have the options set to Suspend. If either these Power settings or systemd's settings above are set to ignore then suspend will not occur.

Please note the systemd change above may not fix everything. It is one thing that needs to change.

1
  • Thank you for your explained solution, but it didn't work. I've updated my question, it seems the problem causes from suspend anyway.
    – Ehsaan
    Oct 21 '16 at 5:51
0

I've solved this problem using similar solution to my previous question.

Simply, I installed nvidia-370 to solve this, now everything is fine.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-370

But I'm not gonna mark this as accepted answer, there might be more cases and this solution might not work for them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.