4

I've used Ubuntu before, but I'm still very new. I just installed 16.10 on a new computer yesterday, and the Wi-Fi has been considerably slower than my Windows laptop. I put the computer together mainly to play Dota 2, and I experience decent ping but constant 5%-10% packet loss while playing. Occasionally, after the computer has been left on for a while, the Wi-Fi connection will drop completely- I can still see networks in the drop down menu, including my home network, but my computer will not reconnect without a reboot. I've looked all over for a solution, but my inexperience has prevented me from getting anything to work. My Wi-Fi card is a Ralink RT2561/RT61, here's some info

The output of sudo lshw -C network

 *-network                 
        description: Wireless interface
        product: RT2561/RT61 802.11g PCI
        vendor: Ralink corp.
        physical id: 6
        bus info: pci@0000:01:06.0
        logical name: wlp1s6
        version: 00
        serial: 00:0e:2e:de:df:c0
        width: 32 bits
        clock: 33MHz
        capabilities: pm bus_master cap_list ethernet physical wireless
        configuration: broadcast=yes driver=rt61pci driverversion=4.8.0-22-generic firmware=0.8 ip=192.168.1.107
 latency=64 link=yes multicast=yes wireless=IEEE 802.11
        resources: irq:17 memory:dfef8000-dfefffff

Here is the output of sudo iwconfig:

 *-network                 
        description: Wireless interface
        product: RT2561/RT61 802.11g PCI
        vendor: Ralink corp.
        physical id: 6
        bus info: pci@0000:01:06.0
        logical name: wlp1s6
        version: 00
        serial: 00:0e:2e:de:df:c0
        width: 32 bits
        clock: 33MHz
        capabilities: pm bus_master cap_list ethernet physical wireless
        configuration: broadcast=yes driver=rt61pci driverversion=4.8.0-22-generic firmware=0.8 ip=192.168.1.107
 latency=64 link=yes multicast=yes wireless=IEEE 802.11
        resources: irq:17 memory:dfef8000-dfefffff

I'm at a loss, I'm very bad at this. If any additional info is needed I can provide it

5

I have a RT2561/RT61 and I finally solved this problem by:

Edit this file as root:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Changing wifi.powersave = 3 to wifi.powersave = 2, which will disable powersave (as mentioned before, from github)

And then restart the network manager as root:

sudo systemctl restart NetworkManager

You don't need to reboot. You can now connect to your wifi device


(This answer is a compilation of previous answers, this method should be highlighted as it saved me from buying hardware)

0

You must use 4.4.0 kernel (used as default in 16.04) then install from source the ralink/mediatek driver for linux "DPO_RT5572_LinuxSTA_2.6.1.3_20121022".

After a reboot you wont lose packets anymore :).

You need kernel 4.4.0 because newer kernel 4.6+ had a change in API so the, very old, driver ralink not compile/work and without it you get packets loss.

In my rt2800usb.conf i setted also "options rt2800usb nohwcrypt=Y swenc=Y fwlps=N ips=N" and turned off wifi power management.

0

Actually

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/g' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Should work better according to this from github

As it shows 0 = use default, 1 = ignore, 2 = disable, and 3 = enable

0

The solution given to a similar problem here seems to have helped greatly but is not the accepted answer.

First, open a terminal and run the following command to edit the file.

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 0/g' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Finally, sudo systemctl restart NetworkManager (or reboot).

The command edits the file: /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf to change: wifi.powersave = 3 to this instead: wifi.powersave = 0

  • You should upvote the linked answer if it has helped you. I have placed a close request marking the question as a duplicate so that it links to the answer. However, because the answer was not accepted as the solution on the previous question, I went ahead and edited your answer to include the steps with a link to the original source as it is not proper to provide a "link only answer". – mchid Oct 20 '16 at 6:38
  • Also, I went ahead and used sed to edit the file instead of gedit because it is quicker and more impressive :). – mchid Oct 20 '16 at 6:54

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.