3

I am running 16.04 on my desktop pc and when I add a second monitor it causes the screen to flicker, especially when interacting with GNOME.

I have an amd radeon gpu. lspci shows

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] [1002:67b1] (rev 80)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Hawaii PRO [Radeon R9 290] [1462:2015]

The xrandr ... --scale 1.0001x1.0001 hack, from here, did not help.

Any idea how I can fix this so I can get back to using multiple monitors?


Additional details

The flickering seems to be caused by interacting with gnome desktop env.

Here is a list of actions that cause flickering:

  • Opening, and using, the search box from the launcher(this is the worst flickering)
  • Using alt+tab
  • Clicking on the desktop
  • Clicking anywhere on a screen after clicking on the desktop of the other screen

Weirdly, interacting with the toolbar at the top of either screen does not cause any flickering.


Kernel 4.4.0-43-generic

  • I've had similar issue with Gnome on Fedora 22 a while back and with Deepin ( which seems to be based on GNOME) on same laptop that has ATI Radeon x1200 card. From what I've researched online, so far there's no general fix. Some people suggested upgrading the drivers or installing the proprietary ones, but with AMD terminating support for some of the older cards, that solution is not ideal. Hope there will be a good answer to this question, as so far there's nothing satisfactory – Sergiy Kolodyazhnyy Oct 26 '16 at 6:39
  • Yeah, this is driving me crazy because my Asus zenbook (running 16.04) can handle three monitors no problem. It has to be related to the amd fiasco. If I had known about the support changes when I built my pc I wouldn't have gone amd. – moss Oct 27 '16 at 16:02
  • My REGULAR screen always flickers. Just ignore it. I don't think there's much to fix. – Hayden Stites Nov 1 '16 at 17:28
0

I have a mixed system (ATI and NVIDIA) with two displays, which experienced some flickering and other issues.

I had found that basically feeding what xrandr output back into itself would sometimes fix it until the next reboot. So I kept digging. Eventually, I found that clarifying some of the parameters in the xorg.conf file would fix it. But the setup was still a bit temperamental.

NVIDIA has greatly improved the installer for their proprietary drivers (which I need for CUDA, and it use to be a nightmare to keep them up-to-date). With it, they offer to configure the xorg.conf file for you. There is nothing "magic" in the generated configuration, just that it explicitly lists every device and display. Everything has worked since then. Maybe running through the AMD installer just for its configuration of X11 is worth while, even if you revert the drivers afterwards.

If not, then man xorg.conf, but it is dense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.