22

I am using Ubuntu 16.04 and I am stuck into blue screen with no message. Its just showing a cursor nothing else. booting Screenshot

Any help is appreciated.

  • This does not look like a Ubuntu 16.04 without extensive changes. Please add additional info to your question on how you changed your base install. – Phillip -Zyan K Lee- Stockmann Oct 19 '16 at 20:24
  • It is ubuntu 16.04 this screen appears after the boot process – Deepak Mahakale Oct 20 '16 at 2:06
  • In my case the issue popped up after installing skypeforlinux (from a .deb package downloaded from skype.com). Switching to a character terminal, uninstalling it and then rebooting took me back to the previous (working) state. – dezso Jan 20 '18 at 18:55
43

I fixed this by rebooting. At the login screen, I switched to a terminal ctrl+alt+F1 and then running sudo apt-get upgrade. That would not run, but I was told to use sudo dpkg --configure -a. After I ran sudo dpkg --configure -a, then I ran sudo apt-get upgrade. Lastly, I ran reboot. This solved the problem.

| improve this answer | |
  • 4
    Thanks, It's works for me, the short cut was ctrl+alt+f1 to switch to terminal – NicoMinsk Feb 7 '17 at 20:20
  • 2
    Same for me. Thank you. It solves the problem for my ub 16.04. – Abdulaziz Apr 24 '17 at 16:06
  • Unfortunately in my case screen turns black after pressing ctrl + alt + F1 . I can't find any terminal. – Md. Abu Nafee Ibna Zahid May 30 '18 at 5:42
  • Worked for me! didnt have to do the second part, only sudo apt-get upgrade using ubuntu 16.04 – chelo_c Apr 6 '19 at 3:54
  • ctrl + alt + F3 did the trick for me, then dpkg fixed the problem for me. – Nathanial Jun 18 '19 at 15:34
4

This happened to me a couple days ago. I waited until it said it had internal error, and I hard rebooted it (holding down power button).

On Ubuntu bootup, you have your OS selection screen. It's a purple screen showing your possible options for bootup. Use the arrow keys and goto Advanced Options for Ubuntu.

And then select: Ubuntu, with Linux 4.4.0-31-generic (recovery mode)

It'll run a lot of code until you reach a link screen.

Do the fsck option, and it should clean and fix your OS, and do the dpkg option. It will repair the packages. And then reboot. This fixed mine.

And then if you want you can do clean to free up some space

Hope this helps, Dallin

| improve this answer | |
  • Great, this worked for me in Ubuntu 16.04 – Rohan_Paul Aug 25 '17 at 8:00
  • This does not work for segfault error 6 in libnvidia-glcore.so in Compiz. – NoBugs Aug 7 '18 at 5:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.