1

I have tried to set my default browser to a github installation of qutebrowser. For this purpose, I have a /home/anaphory/.config/qutebrowser.desktop file containing

[Desktop Entry]
Version=1.0
Name=Qutebrowser
GenericName=Web Browser
Comment=View and edit files
MimeType=text/html;
Exec=bash -c "source /home/anaphory/anaconda3/bin/activate qutebrowser; qutebrowser"
Icon=/home/anaphory/.config/qutebrowser.svg
Type=Application
Terminal=false
Categories=Network;Utility;X-Python;
StartupWMClass=Qutebrowser
X-Desktop-File-Install-Version=0.20

I have a script inside /home/anaphory/anaconda3/bin, which is part of $PATH due to .profile, also stating source /home/anaphory/anaconda3/bin/activate qutebrowser; qutebrowser – Both under x-www-browser and gnome-www-browser.

I have set /home/anaphory/.config/qutebrowser.desktop as default handler:

$ xdg-mime query default x-scheme-handler/https
/vol/home/kaipingga/.config/qutebrowser.desktop

(also for text/html and x-scheme-handler/http). The .desktop works from my applications starter bar, and x-www-browser and gnome-www-browser start qutebrowser from the terminal.

Still, xdg-open http://askubuntu.com, clicking a link in emacs, etc. opens it in Firefox, and “Run” (Alt+F2) x-www-browser runs Firefox.

My settings→Default Applications are still set to Firefox, because that drop-down list only shows Firefox and Chromium. I don't have root permissions.

0

Can you select it in the default application list if you put your desktop file in ~/.local/share/applications instead?

Also, some applications also use the $BROWSER environment variable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.