2

I'm trying to use my Traktor Audio Interface as standard output device. Under Windows this is really simple but so far I couldn't get it working.

My first try was to use this alsa config and to define it as default like this:

pcm.!default {
   type plug
   slave.pcm T10_pair1
}

ctl.!default {
    type plug
    slave.pcm T10_pair1
}

I can use it by specifying the audio device but my default clause seems to have no effect.

mpg123 -a T10_pair1 ./sound.mp3 # this plays via Traktor Audio

mpg123 -a default ./sound.mp3 # this still plays via my onboard sound card

PulseAudio detects the Traktor Audio 10 but doesn't let me choose it as output device.

pavucontrol Configuration pavucontrol Output Devices

list-cards output

list-sinks output

0

I've the exact same problem. Use the following shell command :

pactl load-module module-detect

Then your device should appear in the output list.

  • This works but I have to do it after every restart. Have you found a way to permanently set Traktor Audio as default audio interface? – fap Feb 6 '17 at 22:01
  • Try to edit /etc/pulse/default.pa and add "load-module module-detect" – sylr Feb 7 '17 at 17:28
  • It is already in the config, sadly didn't fix the problem. I'll accept your answer but will accept another answer that persists the fix across reboots. – fap Mar 11 '17 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.