-1

[UPDATE]

As per fkraiem's suggestion below, about the rabbithole (indeed, it does feel like that!), this is the first problem I encounter, and the reason I'm trying to install glib et al.

After running ./configure with pspp-0.10.2:

configure: error: The following required prerequisites are not installed. You must install them before PSPP can be built:

cairo 1.5 or later and pango 1.22 or later (or use --without-cairo)

gthread 2.0 (or use --without-gui)

gtk+ 3.0 version 3.4.2 or later (or use --without-gui)

gtksourceview 3.0 version 3.4.2 or later (or use --without-gui) glib 2.0 version 2.32 or later (or use --without-gui)

Though the Synaptic Package Manager shows I have Cairo 1.14.6-1 installed,

[ORIGINAL POST]

When trying to install glib-2.50.1 on Ubuntu 16.04 I receive the following error -

configure: error: Package requirements (libpcre >= 8.13) were not met:
No package 'libpcre' found

None of the existing posts about this issue provide any solutions.

I have pkg-config installed:

$ dpkg -l | grep pkg-config

ii  libextutils-pkgconfig-perl 1.15-1        all          Perl

interface to the pkg-config utility ii pkg-config 0.29.1-0ubuntu1 amd64 manage compile and link flags for libraries

And have a pckconfig folder in both /usr/lib and /usr/lib/local. Both folders contain:

/usr/local/lib/pkgconfig/blas.pc
/usr/local/lib/pkgconfig/blas-netlib.pc
/usr/local/lib/pkgconfig/dbus-python.pc
/usr/local/lib/pkgconfig/gsl.pc /usr/local/lib/pkgconfig/harfbuzz.pc
/usr/local/lib/pkgconfig/harfbuzz-icu.pc
/usr/local/lib/pkgconfig/ibus-table.pc
/usr/local/lib/pkgconfig/lapack.pc
/usr/local/lib/pkgconfig/lapack-netlib.pc
/usr/local/lib/pkgconfig/libcryptsetup.pc
/usr/local/lib/pkgconfig/libffi.pc
/usr/local/lib/pkgconfig/libgdiplus.pc
/usr/local/lib/pkgconfig/libquvi-scripts.pc
/usr/local/lib/pkgconfig/libR.pc
/usr/local/lib/pkgconfig/notify-python.pc
/usr/local/lib/pkgconfig/pango.pc
/usr/local/lib/pkgconfig/pangocairo.pc
/usr/local/lib/pkgconfig/pangoft2.pc
/usr/local/lib/pkgconfig/pm-utils.pc

Regarding the PKG_CONFIG_PATH

$ pkg-config --variable pc_path pkg-config

yields

/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig:/usr/lib
/pkgconfig:/usr/share/pkgconfig

And

ldconfig -v | grep pcre

yields

/sbin/ldconfig.real: Can't stat /lib/i686-linux-gnu: No such file or
directory
/sbin/ldconfig.real: Can't stat /usr/lib/i686-linux-gnu: No such file
or directory
/sbin/ldconfig.real: Path `/lib/x86_64-linux-gnu' given more than once
/sbin/ldconfig.real: Path `/usr/lib/x86_64-linux-gnu' given more than
once
/sbin/ldconfig.real: /lib/i386-linux-gnu/ld-2.23.so is the dynamic
linker, ignoring
        libpcre.so.3 -> libpcre.so.3.13.2       libpcreposix.so.3 ->
libpcreposix.so.3.13.2  libpcre32.so.3 -> libpcre32.so.3.13.2
        libpcre++.so.0 -> libpcre++.so.0.0.0    libpcre16.so.3 ->
libpcre16.so.3.13.2     libpcrecpp.so.0 -> libpcrecpp.so.0.0.1
/sbin/ldconfig.real: /lib/x86_64-linux-gnu/ld-2.23.so is the dynamic
linker, ignoring

I'm here because I'm trying to install PSPP v0.10.2 of PSPP. The installation guide cautions that:

* pkg-config (http://pkg-config.freedesktop.org/wiki/).  Versions
  0.18 and 0.19 have a bug that will prevent library detection,
  but other versions should be fine.

But since I'm using 0.29 I assume that bug isn't relevant?

  • You are trying to install PSPP; are you sure it needs glib 2.50? Have you tried the glib from the Ubuntu repositories? – fkraiem Oct 19 '16 at 9:40
  • Good point. But that's where I don't understand why it's falling apart. It requires GTK+ which won't install: checking for BASE_DEPENDENCIES... no configure: error: Package requirements (glib-2.0 >= 2.49.4 atk >= 2.15.1 pango >= 1.37.3 cairo >= 1.14.0 cairo-gobject >= 1.14.0 gdk-pixbuf-2.0 >= 2.30.0) were not met: No package 'glib-2.0' found No package 'atk' found Package 'glib-2.0', required by 'pango', not found – lithic Oct 19 '16 at 9:43
  • Most likely, you just need to install the GTK+ development files from the repositories (package libgtk3-dev). – fkraiem Oct 19 '16 at 9:45
  • I have libgtk3-dev (version 3.18.9-1ubuntu3.1) but still no success – lithic Oct 19 '16 at 10:22
  • 1
    It is very unclear what your actual problem is, so please edit your question to describe the first problem you encounter when trying to install PSPP. As it is, it seems you are trying to apply the wrong solution to it. – fkraiem Oct 19 '16 at 10:29
0

For anyone encountering this question later in time. I've ran into similar problems compiling pspp on ubuntu 16.04. The packages I installed (sudo apt install) to solve the issue were as follows:

sudo apt install libxml2-dev
libcairo2-dev
libreadline-dev
libglib2.0-dev
libgsl-dev
libgtk-3-dev
libgtksourceview-3.0-dev

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.