3

I am trying to connect from an Ubuntu 16.04 workstation to another Ubuntu 16.04 workstation on my local LAN.

I have enabled Desktop Sharing as per the official documentation.

I have no confirmation required, no password required, and allow others to control your desktop. The machine is only accessible on my LAN.

There is no mention of how to connect to the desktop once you have enabled it.

I tried using the default installed Remmina Remote Desktop Client, and have tried both VNC and RDP. Neither works.

I have confirmed access, as I am able to ssh to the remote instance.

How can I connect to my remote desktop?

0

The steps you mentioned that you have performed would be specific if you were on the same network or connecting to a remote machine with it's IP exposed with no firewalls.

If the host machine (as in almost all cases) is connected to a router and have a provide IP you would have to perform port forwarding to the computer you want to connect to. The router port to forward is 5900 TCP. You'll also have to ensure you have not blocked port 5900 though the host's firewall. Also ensure to allow connection from the client's IP via /etc/hosts.allow.

Summary of client's access to the server:

1) Port forwared to the host IP in the routher (tcp 5900)
2) Firewall's port 5900 open
3) Access granted to the client's IP address via /etc/hosts.allow

/etc/hosts.allow:

# /etc/hosts.allow: list of hosts that are allowed to access the system.
#                   See the manual pages hosts_access(5) and hosts_options(5).
#
# Example:    ALL: LOCAL @some_netgroup
#             ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "rpcbind" for the
# daemon name. See rpcbind(8) and rpc.mountd(8) for further information.
#

ALL: [remote desktop client's ip here]

You mentioned Ubuntu's default Desktop Sharing. That is the one I'm addressing. It doesn't use rdp so you can leave that protocol along. Just concentrate on the VNC capable clients. The Remmina Remote Desktop Client will work. Just make sure you have it set for VNC and not the other choices.

You have already specified port 22 (ssh) is working which means that port is forwarded. Now the same way you setup and tested ssh, you will have to do the same thing with port 5900, for vnc.

You have already specified what you need in the Vino configuration which is:

1. Allow other users to view your Desktop (Checkmark)
2. Allow other users to control your Desktop (Checkmark)
3. You must confirm (No Check mark)
4. Require the user to enter password (optional)
5. Automatically configure UpNp router (optional)
6. Show Notification area icon (optional)

Only three settings (highlighted in bold) is required for the connection. The other items are optional.

Just set the above configuration, close and connect with a VNC enabled client. While the Remmina client will work, I used vinagre to test and prepare thses steps.

0

in my similar situation, after, I have checked my router settings: "Port forwarding" and "uPNP". I have found twice opened port "5900" from my previous very old game with Remote access to my other Ubuntu computer, currently uninstalled. History: previously I have used static internal network address of my machine under control and used Port forwarding in my router. But today I have decided to use "uPNP" - and duplicated port appears. Solution: in router setting - remove all old port configurations. Regards.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.