3

This question already has an answer here:

I have been using vmware horizon client on Ubuntu 16.04 but yesterday upgraded to 16.10(I regret that now :( ) since then vmware client is throwing the below error:

/usr/lib/vmware/view/bin/vmware-view: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

I googled the same error and found this link and tried the answer 2(as answer 1 seemed to be more on why we get this error) mentioned there but I am still getting the same error.

I am thinking of reinstalling 16.04 LTS but just wanted to try my luck here..

Any help?

marked as duplicate by David Foerster, Eric Carvalho, Charles Green, user364819, Zanna May 4 '17 at 5:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    look at my comment here, Tested on my 16.10 64 bit install, no issues askubuntu.com/questions/838949/… – doug Oct 18 '16 at 22:43
  • 1
    Try to check if it is there: /usr/lib/x86_64-linux-gnu/libpng12.so.0 – Rohitt Vashishtha Oct 19 '16 at 1:54
  • Try sudo apt install libpng12-0 – GrannySez Oct 31 '16 at 5:55
  • @GrannySez I tried your suggestion but I am getting this error: E: Package 'libpng12-0' has no installation candidate – javanoob Oct 31 '16 at 6:11
  • @RohittVashishtha no it is available here /usr/lib/x86_64-linux-gnu – javanoob Oct 31 '16 at 6:13
3

It seems VMware actually ships libpng12.so.0 with the client. You can link to it with this command:

sudo ln -s /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0 /usr/lib/x86_64-linux-gnu/libpng12.so.0
  • Which vmware product? – user3063045 Nov 29 '16 at 20:18
  • 1
    There is no lib directory inside /usr/lib/vmware/ – javanoob Dec 6 '16 at 1:54
  • This works for me sudo ln -s /usr/lib/x86_64-linux-gnu/libpng16.so.16 /usr/lib/vmware/libpng12.so.0 – Foton Feb 2 '17 at 9:25
  • Thanks ! Solved my problem for VMWare Horizon Client 4.6.0 on a Ubuntu 16.04 distro – FrancescoM Dec 13 '17 at 15:48
2

I tried linking the VMware provided libpng12.so.0 file and still got the lib dependency issue. Installing the DEB files directly did resolve it though:

http://packages.ubuntu.com/xenial/amd64/libpng12-0/download http://packages.ubuntu.com/xenial/i386/libpng12-0/download

  • 2
    Could you add how to install them? Did you run sudo apt install -f afterwards? – Zanna Mar 30 '17 at 16:01
2

In Ubuntu 17.04 you can create these two symbolic links as a workaround.

sudo ln -s libudev.so /lib/x86_64-linux-gnu/libudev.so.0
sudo ln -s libpng16.so /usr/lib/x86_64-linux-gnu/libpng12.so.0
  • 1
    where do you put these symlinks? – svandragt Nov 10 '17 at 10:51
  • 2
    This doesn’t really help if libpng12 is expected: libpng12.so.0: version 'PNG12_0' not found – rumpel Jan 7 '18 at 7:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.