I just upgraded to Ubuntu 16.10 and after the restart the display light flickers constantly, regardless of the application running. The flickering starts when the login screen is shown. I am using a Lenovo Thinkpad E540.

I have NVIDIA GeForce GT740M with the driver

  X.Org X server -- Nouveau display driver from xserver-xorg-video-nouveau

Other driver options, which I'm not eager to try (since last time the entire graphics display stopped working):

  NVIDIA binary driver 367.57 (proprietary, tested)
  NVIDIA binary driver 340.98 (proprietary)

Output of lspic:

    lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

My current kernel version is

   uname -r

I have tried this solution here but it didn't work.

Has anyone a workaround for this very annoying issue?


3 Answers 3


This bug first appeared in bug reports in Kernel version 4.6.2 and users found downgrading to 4.5.4 fixed it. Upgrading to 4.7 did not fix it.

Panel Self Refresh (psr) bug

Links to links to other bug reports say it can be fixed by modifying grub's kernel boot command line with:


To do this you need to gksu gedit /etc/default/grub.

Search for quiet splash and insert i915.enable_psr=0 in front of the last double quote. There may be other options but minimally it should look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0"

Save the file and type sudo update-grub. Then reboot and the flickering should be gone.

You can read more at: (LCD flickering on Thinkpad T440p (Haswell) with kernel 4.6-rc4 (PSR enabled))

Frame Buffer Compression

At the same time psr was introduced in the 4.6 kernel major revision, fbc (Frame Buffer Compression) support was also introduced. It prevents repainting the screen when it doesn't change. An imperceptible power savings feature (.06 watts). To turn update the grub kernel command line (as described above) by adding:


The final solution is to turn off i915 mode setting altogether with the grub kernel command line option:


Please note these can't be tested on my system and I can only go by bug reports from users with similar systems to yours.

  • 1
    I don't have any line with "quiet nosplash" only this line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" is it that one? if so you mean change it somthing like GRUB_CMDLINE_LINUX_DEFAULT="quiet splash 1915.enable_psr=0"?
    – wasp256
    Commented Oct 29, 2016 at 9:11
  • I have tried it with this additional option now, but the backlight still flickers...
    – wasp256
    Commented Oct 29, 2016 at 10:37
  • I've updated the answer with two additional options - fbc (frame buffer compression) and i915.modeset disabling. Commented Oct 29, 2016 at 12:33
  • Thanks for the effort! I have tried all the above options unfortunately without success...the backlight still flickers
    – wasp256
    Commented Oct 30, 2016 at 9:25
  • I've done it directly in the grub console (adding i915.enable_psr=0 at the linux line), it works.
    – Yves
    Commented Nov 4, 2016 at 8:27

I have the same problem. I have tried all listed drivers without any success. Eventually I booted with the previous kernel (v.4.4.0-45) and this solved the problem.

  • As of October 22, 2016 (when you posted your answer) Kernel 4.4.0-45 was the most recent (not previous) kernel version I think. Commented Oct 23, 2016 at 15:27
  • 1
    Its is the same for me with my lenovo notebook. I upgraded to 16.10, which uses a 4.6 Kernel and the screen flickers. When booting with the old 4.4 kernel, the screen is okay. Maybe it is the same as this bug: bugs.launchpad.net/ubuntu-mate/+bug/1558736?comments=all
    – eDeviser
    Commented Oct 25, 2016 at 19:33
  • Same problem: Lenovo Edge 540, NVIDIA GeForce GT 740M Commented Oct 28, 2016 at 12:55
  • @WinEunuuchs2Unix: The newest kernel installed on my system now is and the problem is still going on
    – wasp256
    Commented Oct 28, 2016 at 17:33
  • @HåkonHægland: Yes I think we have the completly same Laptop model (as mentioned in my orginal post)
    – wasp256
    Commented Oct 28, 2016 at 17:33

The problem does indeed seem to be widely reported.

I have what appears to be exactly the same problem on a Lenovo e540 equipped with dual boot ubuntu gnome 16.10/16.04. The problem does NOT seem to exist on 16.04 but it does on 16.10. My Lenovo has integrated Intel graphics Haswell Mobile on a Core i3-4100M and therefore has the i915 graphics driver.

Interestingly I also have a Clevo with Intel integrated graphics: Core i3-3110M with Ivybridge Mobile graphics, which also uses the same i915 graphics driver, running Ubuntu Gnome 16.10 and on this computer the problem DOES NOT EXIST.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .