21

Pretty much as the question says. I followed the steps to set up the online accounts through system settings but my drive folder is not showing up on Nautilus.

7
  • 1
    Followed what steps? I have google-drive in nautilus on 2 different laptops in 16.04 so does work. Did you do something like this - webupd8.org/2016/03/use-gnome-318-google-drive-integration.html
    – doug
    Oct 19, 2016 at 0:36
  • Yes I followed those steps. I noticed that the options under the Google account (first and second image in the link you sent) is different to the options I'm presented with: my screen.
    – James
    Oct 19, 2016 at 7:16
  • 3
    That looks more like the unity-control panel. Try from terminal gnome-control-center online-accounts (- if you added google to the unity-control-panel it it appears you did then maybe first open it & remove unity-control-center credentials
    – doug
    Oct 19, 2016 at 22:23
  • 1
    It would be good to have an accepted answer with this solution.
    – Phoenix87
    Dec 26, 2016 at 14:02
  • 1
    You can answer your own question
    – Phoenix87
    Dec 26, 2016 at 21:00

6 Answers 6

22

This is the solution that worked for me (source):

Install GNOME Control Center (GNOME System Settings) and GNOME Online Accounts:

sudo apt-get install gnome-control-center gnome-online-accounts

Open the GNOME Online Accounts:

gnome-control-center online-accounts

From there add your Google account and make sure "Files" is enabled:

GNOME Online Accounts window

You should now be able to access your Google Drive files from the Files (Nautilus) app which appears alongside other mounted drives and, in my case, is named with my email address.

8
  • 5
    This isn't working for me on Ubuntu 16.04. Everywhere I look online I see a screenshot like what you show, but my online accounts interface is different. Instead of just "Mail", "Calendar", etc. I have toggles for "Empathy", "Shotwell", "Evolution Data Server", etc. and the only Google Drive related one is "Google Drive search plugin". With everything enabled I still don't see the Google Drive files in Nautilus.
    – Colin
    Mar 21, 2017 at 17:46
  • @Colin I thought the same, but as this answer suggests, you should install this gnome-control-center. The one you currently have is different (I know it looks similar. But it's different). Just tested it on my Ubuntu 16.04 LTS and it is working. Note: Then you will have two, separate "Settings" apps but well... that's the price.
    – modu
    Mar 25, 2017 at 21:40
  • 2
    If it helps anyone else, you should use the terminal command to open the Gnome Control Center. After installing everything, you'll now have 'System Settings', 'Settings', 'Online Accounts', and 'Settings > Online Accounts'. Both Online Accounts options will let you connect to a Google Drive account, but only the 'Settings > Online Accounts' will work for syncing GDrive files
    – AJ Zane
    Jun 3, 2017 at 4:55
  • It's quite confusing to have two different online account interfaces. Is there a way to remove one?
    – MERose
    Jan 19, 2018 at 15:18
  • Something that might work is to run /usr/lib/gnome-online-accounts/goa-daemon --replace. Kudos to bbs.archlinux.org/viewtopic.php?id=203544
    – MERose
    Jan 20, 2018 at 3:04
5

Introduction

Sadly, there is no official Google Drive client yet. I'm assuming you want to access your Google Drive as a local folder.

TLDR: Use a Fuse FS implementation to mount your Google Drive locally.

This site explains it better than I possibly can, but I'll write the minor instructions in case the link goes down.

Installation

  • Add the repository to your sources.
  • Update your apt sources.
  • Install google-drive-ocamlfuse

The following commands execute the above three steps respectively:

sudo add-apt-repository ppa:alessandro-strada/ppa
sudo apt-get update
sudo apt-get install google-drive-ocamlfuse

Usage

The following commands are to be run in a terminal.

  • Authenticate google-drive-ocamlfuse with your Google account by simply running google-drive-ocamlfuse.
  • Now, in the browser tab that opens, follow the instructions to authenticate.
  • Create a new directory where you want the Google Drive to be mounted. For example, run mkdir ~/gdrive to create a new gdrive directory in your home directory.

The steps till now were just one-time tasks. From now on, you need to type the following command to mount your Drive:

google-drive-ocamlfuse ~/gdrive

Now you can access all your Drive documents inside that folder.

When you're done with everything, type sudo umount ~/gdrive to unmount the Drive.

Extra

You might want to automatically mount the Drive when you login. To do this, run 'Startup Applications' and add a new entry to it with the command:

google-drive-ocamlfuse ~/gdrive
1
  • google-drive-ocamlfuse has some malfunction. For ex. when sync files then google drive doesn't recognise the type of file anymore (this is what I got in 5 sec. of testing). Jun 5, 2017 at 7:35
2

I tried some of James's answers unsuccessfully. A certificate update worked for me:

sudo update-ca-certificates
0
2

Problem you're having is that there is a Unity online account manager installed in 16.04 by default. (Several mentions of this in the comments led me to figure out how to make it work...)

You can add the Gnome online account manager, but if you don't remove the Unity online account manager first you won't get the Gnome online account options even if you install them and run a Gnome desktop...

sudo apt-get remove unity-control-center unity-control-center-signon unity-control-center-faces credentials

Then you can install the Gnome tools and it works when you look in System Settings...

  sudo apt-get install  gnome-control-center gnome-online-accounts

Now go to System Settings => Online Accounts and add a Google account... Then you get the file mount for Google Drive in Nautilus (if you've enabled the check box).

1

Sadly there is no Google Drive Linux client at the moment as you may see here. As far as I know what you get when you sync with your google account in ubuntu is the ability to search google docs in the dash but nothing more.

If you want to use google drive with Ubuntu you can use inSync which is a google drive client for linux (and mac os, windows and raspberry pi),for me it works flawless.

I hope my answer have helped you.

1

Installing gvfs-backends packages solved this issue for me.

1
  • Great answer, this one worked for me!
    – Pekov
    Jul 12, 2020 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.