9

I can't install teamviewer. dpkg is complaining about an unresolved dependency:

# dpkg -i teamviewer_11.0.67687_i386.deb 
Selecting previously unselected package teamviewer:i386.
(Reading database ... 169209 files and directories currently installed.)
Preparing to unpack teamviewer_11.0.67687_i386.deb ...
Unpacking teamviewer:i386 (11.0.67687) ...
dpkg: dependency problems prevent configuration of teamviewer:i386:
 teamviewer:i386 depends on libpng12-0.

dpkg: error processing package teamviewer:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 teamviewer:i386

apt-cache search libpng12 doesn't return any match

Could anybody help me to solve this issue?

Thanks in advance

5
  • 1
    Wait for a new build, (don't hold breath) or just install the xenial libpng12 package(s). If on a 64bit install then 1st. install the amd64 .deb, then the i386 .deb. (if on 32 bit install then just the i386 .deb) After it or they are installed then install teamviewer. If desired you can use apt for the installs as it resolves dependencies now. Get package(s) from here, packages.ubuntu.com/xenial/libpng12-0 ((- tested & works fine, tv opens slow first time.. – doug Oct 18 '16 at 22:19
  • 1
    @doug This should be an answer. :) – fkraiem Oct 19 '16 at 0:28
  • Hi @doug ! Thanks for the answer. It has solved the problem. – rssh22 Oct 19 '16 at 5:57
  • 1
    Try sudo apt-get -f -y install. – zx485 Nov 25 '16 at 0:06
  • @zx485 that did the trick. :) (y) – Sifar Apr 3 '17 at 5:42
9

Teamviewer depends on libpng12-0, which is replaced in yakkety (16.10) with libpng16-16. You can try using the libpng12-0 package from the xenial repository:

$ wget http://se.archive.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_i386.deb
$ dpkg -i libpng12-0_1.2.54-1ubuntu1_i386.deb
$ rm libpng12-0_1.2.54-1ubuntu1_i386.deb
2
  • /sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link – wayofthefuture Apr 25 '17 at 21:59
  • This solution worked for me in 17.10 running GNOME. It's more than a little exasperating that dpkg or apt-get is so behind-the-times as not to be able to solve this on its own. I thought that was what package managers are for! – Adrian Keister Jan 26 '18 at 18:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.