1

I have this lan ethernet:

03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
        Subsystem: ASRock Incorporation AR8151 v2.0 Gigabit Ethernet [1849:1083]
        Kernel driver in use: atl1c
        Kernel modules: atl1c

It card is a Gigabit Ethernet, but in ubuntu 16.04 and 16.10 only woks at 100Mb/s

Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x0000003f (63)
                               drv probe link timer ifdown ifup
        Link detected: yes

I mesured the connection speed of this ethernet with iperf and rally is 100Mb/s

It is not cable problem because I try a laptop in the same point with the same cable and it runs at gigabit.

How can I do to solve this?

7
  • "Advertised link modes: Not reported" Wierd! Is there any improvement with the terminal command: sudo ethtool -s eth0 speed 1000 duplex full autoneg on ? If so, we can propose a possible fix.
    – chili555
    Commented Oct 18, 2016 at 21:15
  • No, after execute this command in terminal ethtool keep saying "speed 100Mb/s" and "Advertisement link modes: Not reported"
    – David
    Commented Oct 18, 2016 at 22:33
  • Please check here: forums.linuxmint.com/viewtopic.php?t=225141 Any improvement?
    – chili555
    Commented Oct 18, 2016 at 23:12
  • I disabled ipv6 binarytides.com/disable-ipv6-ubuntu and after disable ipv6 the problem remains :(
    – David
    Commented Oct 19, 2016 at 19:50
  • I did not find any solution. Finally buy an ethernet pci. I chose one with the RTL8169 chipset that works perfectly on ubuntu.
    – David
    Commented Nov 21, 2016 at 20:53

1 Answer 1

0

I was the user who started the thread linked to by chili555 in the Linux Mint forums: https://forums.linuxmint.com/viewtopic.php?t=225141

While disabling the IPv6 worked for Linux Mint 18, it did not work for Ubuntu 16.04. The solution is installing the Linux driver from Atheros. I followed this post on the Ubuntu Forums to get it working: Atheros AR8151 ethernet on Asus P8H67-V

Unfortunately the link in the post to the driver itself is dead. I found that it is available on Ubuntuusers.de, a German language Ubuntu forum. You can download the driver here: Download AR81Family-linux-v1.0.1.14.tar.gz

I hope this helps.

1
  • Maybe it works, but recompiling every kernel upgrade is tedious. I finally bought a well supported pci ethernet. Thanks for the effort Mark
    – David
    Commented Jun 20, 2017 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .