13

AMD has drivers up listed for 14.04 and 16.04. Trying to install the 16.04 drivers on 16.10 gives me

ln: failed to create symbolic link '/usr/bin/amdgpu-pro-uninstall':
File exists

Is there any way to get them to run? Thanks.

EDIT: I'm using an RX 480, and the drivers had installed fine on 16.04, but aren't working on a clean install of 16.10

16.04 Drivers from the official AMD Website: http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%E2%80%93Release-Notes.aspx

  • 2
    We need more info, like GPU model and where you downloaded from – You'reAGitForNotUsingGit Oct 18 '16 at 20:45
  • Edited that in. I didn't think it mattered because you need a 300 or 400 card for PRO support & you can only get them from the AMD website. – xicronic Oct 18 '16 at 23:35
  • 1
    I don't think that error you give is the actual issue. You should edit the complete output into your question, or put in it a pastebin if it's too long. – TheWanderer Oct 19 '16 at 0:13
  • 1
    Having the same problem with fresh install of Ubuntu 16.10 and AMD R9 380. Downloaded drivers from AMD website. First attempt to install:sudo ./amdgpu-pro-install tee: /etc/aptsources.list.d/amdgpu-pro.list: No such file or directory deb file:/var/opt/amdgpu-pro/ ./ – Chris Oct 19 '16 at 5:48
  • @Chris @xironic I had the same issue when I was trying to install the driver for Ubuntu 17.1 after trying to install the wrong driver version for Ubuntu 16.x on 17.1. I cd into the folder /usr/bin/ and removed amdgpu-pro-uninstall after that I installed the right version and it worked – Matthias Herrmann Jul 4 '17 at 15:50
6

Try this:

  1. Edit amdgpu-pro-install in amdgpu-pro-driver folder.
  2. Modify line number 67 with this:

    echo ${dir}${etc}${dir}${sourceparts}/amdgpu-pro.list
    
  3. Save it.

  4. Try to install again

In my case it has worked, the driver was installed but only on kernel 4.4, not in the new 4.8. Can someone confirm this?

| improve this answer | |
  • I am on kernel 4.8. This fix worked for me. Thanks! – Thomas Antony Nov 12 '16 at 21:50
  • Cool, this worked for me with amd-gpu-16.50 on Ubuntu 16.10. Thanks :-) – We are Borg Jan 20 '17 at 10:18
  • Well, it kind of worked. Got a Error! Bad return status for module build on kernel: 4.8.0-42-generic (x86_64) nestled in between all the other output - so I uninstalled immediately just to be on the safe side. The appropriate log file referenced on the next line contains this: hastebin.com/gobasuguxu Thoughts? – starbeamrainbowlabs Mar 22 '17 at 20:06
2

At the time of writing, AMDGPU-PRO does not support Ubuntu 16.10; 16.10 uses Linux 4.8 and AMDGPU-PRO "is only intended to work with Linux 4.7 kernels and older while the official focus is on Linux 4.4 of Ubuntu 16.04." Source.

You may be able to do some hacking to get it to work, such as this user's workaround, but this is obviously unsupported and could affect system stability.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.