2

I've followed this guide right from the beginning to the end (including removing Libre): http://tecadmin.net/install-apache-openoffice-on-ubuntu-debian/#

When I get to the latter part of step 3 (desktop integration), I get the following error:

jdave@eng-tp06-l:~/en-US/DEBS/desktop-integration$ sudo dpkg -i openoffice4.1-debian-menus_4.1.2-9782_all.deb

(Reading database ... 286456 files and directories currently installed.)
Preparing to unpack openoffice4.1-debian-menus_4.1.2-9782_all.deb ...
Unpacking openoffice-debian-menus (4.1.2-9782) ...
dpkg: error processing archive openoffice4.1-debian-menus_4.1.2-9782_all.deb (--install):
 trying to overwrite '/usr/bin/soffice', which is also in package libreoffice-common 1:5.1.4-0ubuntu1
/usr/bin/gtk-update-icon-cache
gtk-update-icon-cache: Cache file created successfully.
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160701-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 openoffice4.1-debian-menus_4.1.2-9782_all.deb

Using the command given on the site results in a missing file error as well which is why I modified it to use the entire package name in the folder. I'm relatively new at using Ubuntu so I'd love some help.

  • 5
    Libreoffice and Openoffice conflict when installed at the same time. – Android Dev Oct 18 '16 at 20:26
  • 2
    Looks like,even though I thought I'd completely removed Libre, there were still some remnants causing the issue. I used sudo apt-get remove --purge libreoffice-common and that did it. Thank you! – Jvalant Dave Oct 18 '16 at 20:40
  • Mark it solved with your answer. – Matt O. Oct 18 '16 at 22:03
4

Libre was the one causing the issue. I thought I had removed it but there were still some remnants. To remove them, I used

sudo apt-get remove --purge libreoffice-common

and then tried the previous command again and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.