4

This question already has an answer here:

After a new install of Kubuntu 16.10, I'm unable to convince Network Manager to manage my wired network interfaces. I've already confirmed that I can use the wired interfaces by configuing them manually in /etc/network/interfaces and using ifup/ifdown. In preparation for Network Manager, I have removed any mention of the wired interfaces from /etc/network/interfaces:

# cat /etc/network/interfaces
auto lo
iface lo inet loopback

After messing around with it (e.g. setting managed=true), I've restored NetworkManager.conf to its original state:

# cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

After each change, I always restart Network Manager using systemctl restart network-manager, but there is never any change. Nothing I do will convince Network Manager to touch those two wired interfaces. For example, using nmcli to explicitly instruct NM to manage one of them has no effect:

# nmcli d
DEVICE           TYPE      STATE      CONNECTION
wlx0002723c09df  wifi      connected  JRT-AIR
enp0s31f6        ethernet  unmanaged  --
enp11s0          ethernet  unmanaged  --
lo               loopback  unmanaged  --
# nmcli d set enp11s0 managed yes
# nmcli d
DEVICE           TYPE      STATE      CONNECTION
wlx0002723c09df  wifi      connected  JRT-AIR
enp0s31f6        ethernet  unmanaged  --
enp11s0          ethernet  unmanaged  --
lo               loopback  unmanaged  --
# nmcli d show enp11s0 | grep STATE
GENERAL.STATE:                          10 (unmanaged)

All the documentation and help information I've found says that I need to edit either /etc/network/interfaces or /etc/NetworkManager/NetworkManager.conf (e.g. setting managed=true in NM.conf), but none of these edits has had any effect. Both ethernet interfaces are always listed as "unmanaged" in nmcli, and NM refuses to create any connections using them. Can anyone suggest what I might be missing here?

As an additional note, when booting a live USB on this machine, Network Manager happily manages these wired interfaces as expected. Comparing the config files between the live USB system and the installed one, I see no differences relating to network configuration.

Edit: On further investigation, this only happens when the root filesystem is ZFS. I installed to an EXT4 partition, and everything worked correctly. Then, I copied the files from that working installation into a ZFS filesystem and made that copy bootable, and the ZFS copy showed the error, despite having all identical files to the working EXT4 copy.

marked as duplicate by jokerdino Apr 18 '17 at 7:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'm having the exact same problem with Lubuntu 16.10, on a Thinkpad t460s. The root filesystem in this case is btrfs, but it's hard to see how that'd matter. – Mark Reinhold Nov 3 '16 at 16:32
3

from NetworkManager 1.2.4 (ubuntu 16.10) all non-wifi/wwan device are treated as unmanaged

[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

workaround: comment out the content of /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf or remove the file

for details see https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1638842

  • 3
    The correct way to do it is to use an empty /etc/NetworkManager/conf.d/10-globally-managed-devices.conf that will overshadow/overwrite the one in /usr/lib – solsTiCe Jan 2 '17 at 13:41
  • What does this have to do with the root filesystem being on ZFS? – Ryan Thompson Jan 2 '17 at 16:26
  • I faced the same issue after upgrading from 16.04 to 16.10. I had EXT4. The issue has nothing to do with the filesystem type. I think @RyanThompson only compared the /etc/ directory (where usually the configuration files are located) – Zoltan Laczko Jan 2 '17 at 18:33
  • I didn't only compare the /etc directory. I copied the entire root filesystem to zfs using rsync -aHAX, and then only edited files relevant to making the new root bootable (e.g. /etc/fstab and grub config files). So except for any files that I manually edited, everything was identical on the ZFS root relatie to the EXT4 root. I never changed the Network Manager config. – Ryan Thompson Jan 2 '17 at 21:09
  • @RyanThompson: strange. btw I had the same issue and removing the globally-managed-devices config solved the issue. – Zoltan Laczko Jan 2 '17 at 22:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.