20

I have an HP 500-413nl (a desktop) and Windows 10 keeps changing the boot order in UEFI/BIOS every time, so that if I want to boot Ubuntu 16.10 (64-bit) I always have to press F10, thus entering the BIOS setup and changing boot order…

Is there a workaround for my PC? What should I do? I'm a little desperate.

P.S.: I have already disabled "Secure boot" and "Fast/quick boot" in the BIOS and "Fast startup" in Windows options / Control panel.

  • Did you change the boot order in the UEFI/BIOS settings? I had to change the boot order sequence for the drives after creating the dual-boot setup. I'm using an MSI laptop, not HP. – code_dredd Oct 18 '16 at 14:22
  • Did you try renaming the bootloader and change the label to exactly match the Windows version? That might make things stick, at the cost of making the manual boot more confusing. – ubfan1 Oct 18 '16 at 15:43
  • Some HP have a "Customized" boot buried pretty deep in settings: ubuntuforums.org/… and one of later answers: askubuntu.com/questions/244261/… – oldfred Oct 18 '16 at 15:49
  • @ray Yes, I did – JK andy-drew Oct 18 '16 at 15:54
  • @JKandy-drew Dumb question, but did you save the changes at UEFI? I just don't see a reason why Windows would be modifying UEFI/BIOS settings without you asking it to do it (if possible), but I wouldn't be surprised if it's really doing that.. haven't come across this problem. – code_dredd Oct 18 '16 at 16:30
21

I also faced the same issue that Windows 10 (Education) automatically, on startup, moves the Windows Boot Manager EFI entry to the top again. If I changed it, after restarting with Windows, the next boot skipped Grub and directly booted into Windows. This is how I sovled it:

I would recommend the tool EasyUEFI http://www.easyuefi.com/ to view and change some EFI related settings.

  1. Open the tool and select Manage EFI Boot Option

  2. Take a loot at the exiting entries. The two important ones for me are:

    Description:Windows Boot Manager
    GPT partition GUID:{505E666C-00CD-4654-BB80-FBD2C6F9F191}
    Partition number:2
    Partition starting sector:923648
    Partition ending sector:1128447
    File path:\EFI\Microsoft\Boot\bootmgfw.efi
    

    And:

    Description:Ubuntu 16.04
    GPT partition GUID:{505E666C-00CD-4654-BB80-FBD2C6F9F191}
    Partition number:2
    Partition starting sector:923648
    Partition ending sector:1128447
    File path:\EFI\ubuntu\grubx64.efi
    
  3. The next step is to make sure that Windows does not use its own bootmgfw.efi file again, but rather grubx64.efi. To do so, don't move an Ubuntu EFI entry to the top again (i.e. that's the problem we have), but just set the file path for the Windows Boot Manager to \EFI\ubuntu\grubx64.efi. You can also do this from the administrator command line:

    Bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
    

    Now, Windows should not change the EFI settings anymore and on every boot, GRUB is the default. As GRUB ideally already identified your Windows OS, it also contains its value in the grub settings.

  • 1
    If Grub is not configured properly, refer to this or this post to add Windows to Grub, as you can now boot into Ubuntu again. Sorry, but due to insufficient reputation, I could not provide more than 2 links in my response. – maddin25 Jan 7 '17 at 15:06
  • It solved! Thank YOU and ALL who contributed, finally I understood it's a Windows problem/issue (not Linux), and overall I hope this could help others having the same trouble. :) Just use the last command @maddin25 reported. – JK andy-drew Jan 7 '17 at 21:47
  • WARNING!!! May cause a boot manager collision in BIOS! See this question – Kartik Aug 14 '17 at 18:44
  • 2
    @Kartik my post above concerns UEFI and not BIOS, which are two different things (see here) – maddin25 Aug 16 '17 at 9:13
  • Yes. I should have written "during POST". Instead I wrote BIOS, and didn't see it until now. – Kartik Aug 16 '17 at 15:13
2

My Sony laptop was also changing the boot order upon start-up. Another alternative that worked was to use EasyUEFI to disable the Windows Boot Manager EFI entry.

This left the existing Ubuntu boot option as the highest active.

2

I had this problem and solved it by setting a password in the UEFI/BIOS for accessing it. Apparently, when a password is defined, windows can no longer make changes in the UEFI/BIOS. The computer is a Lenovo.

  • On what system? – Elder Geek Apr 24 '17 at 23:23
  • 1
    Thank you for your input and welcome to the site. Please consider editing your answer to provive more information such as the password that you changed and the outcome. – Phil UK Apr 25 '17 at 0:40

protected by Community Sep 3 '17 at 18:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.