6

After crashing my Ubuntu 16.04 with installing nvidia drivers I installed Ubuntu 16.10

However my cursor is not moving anymore. It stays in the upper left corner. It is moving invisible (detected through hovering over icons) I installed Ubuntu without moving mouse...

I tried following without success

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Nothing changed.

sudo service lightdm restart

Neither there. I installed gdm instead but then i was not even able to get to the login gui or even tty. So went back to lightdm.

Reenabling the mousedriver did nothing.

sudo modprobe -r psmouse
sudo modprobe psmouse

Nothing changed.

After installing nvidia driver with

sudo apt-get install nvidia-current

I was able to move my mouse again, however I was stuck in the well known Ubuntu login loop. The common solution with .Xauthority and other solutions did not work. Had these problems with Ubuntu 10.04. Even my resolution was worse after that. After removing the nvidia-driver I was able to login again, but no moving cursor.

Is this a graphics problem? I have a Nvidia GTX 1070 Ti

Any solutions? Thank you.

5
  • 2
    GTX1070 works with 367 or 370 only. Neither are provided by nvidia-current.
    – user589808
    Oct 18, 2016 at 10:23
  • 2
    That did it. After installing nvidia-367 everything works fine. Thank you! Oct 18, 2016 at 10:54
  • I'm having the same problem, only installing nvidia-367 didn't do it. Any ideas? It's a fresh Ubuntu 16.10 install. Dec 26, 2016 at 13:35
  • Holy crap, it worked! Signed up for this site just to say that I owe CelticWarrior my life
    – Fomentia
    Dec 29, 2016 at 16:03
  • This seems to be the official bug report: bugs.launchpad.net/ubuntu/+source/linux/+bug/1646574 Not sure how long it takes for the fix to make it to the official Ubuntu installer though...
    – Sjiep
    Jan 30, 2017 at 19:24

1 Answer 1

0

My first attempt to install the driver caused a login loop. The reason in my case is I didn't disable secure boot after the installation. So, I uninstalled the driver, reinstalled it, rebooted the computer and disabled secure boot.

sudo apt-get remove --purge nvidia-*
sudo apt-get install nvidia-367

remember to reboot and there will be a count down page for you to disable secure boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.