3

I've just upgraded my laptop to Ubuntu Gnome 16.10 and noticed that whenever I type, my touchpad stops responding. This is OK when actually typing, however it renders games unplayable (yes, I sometimes play with a touchpad, don't judge me) and certain proprietary 3D visualization tools that I need for my university studies barely usable without a mouse.

If I'm not mistaken, there USED to be an option to disable such behavior, however, as of this writing, it is gone from the "Mouse and Touchpad" menu. Is there a command or a config file that I could use to fix this problem?

4

The answer by pauljohn32 pointed me to the right direction and after reading through some man pages, I was able to disable the annoying feature. Here's how to do it:

  1. Seems that Ubuntu Gnome 16.10 uses libinput by default, so go to /usr/share/X11/xorg.conf.d.
  2. Find a file called 60-libinput.conf and edit it with your favorite text editor. I used

    sudo vim
    

    however, you can also use

    sudo gedit
    

    or something similar if you prefer a GUI editor.

  3. Find these lines:

    Section "InputClass"
            Identifier "libinput touchpad catchall"
            MatchIsTouchpad "on"
            MatchDevicePath "/dev/input/event*"
            Driver "libinput"
    EndSection
    

    and append Option "DisableWhileTyping" "false" so that the section would look like this:

    Section "InputClass"
            Identifier "libinput touchpad catchall"
            MatchIsTouchpad "on"
            MatchDevicePath "/dev/input/event*"
            Driver "libinput"
            Option "DisableWhileTyping" "false"
    EndSection
    
  4. Restart the X.Org server by restarting gdm or your machine.
  5. Enjoy not having your trackpad lock up every time you press a key.
0

Depends if your toucpad uses synaptic or libinput driver. Both have disable while typing a optional. Depending which desktop you use, there may be a gui for adjusting, more likely if you are on synaptic.

NO need for gui, however. If

synclient -l

Returns setting lisT, all good. Format you run is

synclient Param=Value

You find what you like, then translate into the settings file. You will see disable while typing. Message me if you get stuck there. Am on tablet now, typing is SLOW.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.