4

After having updated Kubuntu from 16.04 (with kubuntu backports ppa enabled) to 16.10 my keyboard does record only a few keys (it ignores most keystrokes).

This happens only in plasma (e.g. Krunner, Application launcher,password dialogues). However, this does not happen in the terminal and in applications (e.g. Libreoffice, firefox, guake, telegram, plasma-discover, kate).

The behavior is irrespective of the keyboard layout chosen (DE,GR,US)

Nonetheless it is very annoying as

  1. I am used to using Alt-F2 + typing to open my applications
  2. I cannot run any GUI applications requiring root (e.g. my own scripts to mount my work network places into my filesystem)

What I have done

Deleting all files under ~/.config containing plasma by running rm *plasma* did not change anything.

Similarly, deleting all files under ~/.cache containing plasma by running rm *plasma* did not change anything.

When I run

killall plasmashell #to stop plasmashell
kstart plasmashell #to restart plasmashell
killall krunner #to stop krunner
krunner #to start krunner

and the following to restart polkit-kde-authentification-agent-1

killall polkit-kde-authentication-agent-1
/usr/lib/x86_64-linux-gnu/libexec/polkit-kde-authentication-agent-1 &

as described in this bug, the aforementioned problems seem to be resolved.

However, they reappear on each restart. Any ideas?

2 Answers 2

8

As described in this bug replacing ibus for fcitx solved my problem:

sudo apt purge ibus
sudo apt install fcitx
sudo dpkg-reconfigure fcitx
sudo reboot

Strange thing, after updating to 17.04 I had to redo the above steps... This is some persistent thing. After updating to 17.10 I had to reinstall ibus to rectify this, and then redo the above steps as this problem recurred. (This however leaves me with the problem described in the linked question).

5
  • 1
    This works for me
    – CrabMan
    Jul 18, 2017 at 14:58
  • I had the same problem on kubuntu 18.10 and this has solved my problem. thanks.
    – fccoelho
    Apr 16, 2019 at 11:56
  • 2
    Purging ibus was enough for me. By purging it, I've noticed it was installed by zoom, which explains why the issue only appeared after rebooting my computer following the installation of zoom a few days back.
    – Yvan
    Jun 10, 2019 at 8:53
  • KDE Neon on Ubuntu 18.04 - didn't work for me. There is also no inbuilt virtual keyboard I can just open, and I can't even get into a terminal session! But the keyboard works without issues outside of Plasma...
    – xeruf
    Jun 26, 2019 at 20:36
  • Thank you! Solved issue for me. Jul 15, 2019 at 7:00
1

KDE on Debian 9 here.

I also looked at the same bug report, but am using a different solution now: I put a small script into ~/.config/autostart_scripts and made it executable:

#!/bin/bash

# necessary for starting ibus which was installed as a dependency of Zoom.
ibus-daemon -d --desktop=KDE

IBus was required for Zoom for me as well, and this solution seems to work for me so far.

Not the answer you're looking for? Browse other questions tagged or ask your own question.