Ubuntu 16.04 Intel® Xeon(R) CPU E5607 @ 2.27GHz × 8 64-bit

HP Laser Jet 1012 using hp-Laser-jet-1012 driver

Each time I print I get an extra page printed at the end of my print job with the error "This error condition occurs by design when an attempt to print with a PCL5e or PCL6 printer driver occurs and is NOT a bug within the product software. Install the correct HP LaserJet Host-Based Printer Driver or the HP LaserJet printing system software for the product." http://support.hp.com/us-en/document/c00063454

My desktop has the correct driver. Therefore after sudo apt-get update - sudo apt-get upgrade I went to http://hplipopensource.com/hplip-web/install_wizard/index.html I download the latest version of HPLIP to get access to new features and bug fixes, as suggested.

I still have the same error. I am lost. Does only have an idea what is the cause of this error -- "Unsupported Personality: PCL"

  • What applications are you printing with? Does it happen with all applications? Commented Oct 18, 2016 at 3:04
  • Sorry didn't think of this. I use Firefox 49.0, Chrome 54.0.2840.59, Thunderbird 45.3.0 and LibreOffice Yes, it happens with every one. Yes it does happen with every print job from every application I print from.
    – Wyght
    Commented Oct 18, 2016 at 20:05

2 Answers 2


Update from https://www.openprinting.org/printer/HP/HP-LaserJet_1010 (some time in the last several years):

The problem of the "Unsupported Personality: PCL" was finally solved by Carl Michal (michal at physics dot ubc dot ca). By analyzing the output of the Windows driver he found out that after the BeginSession operator in the beginning of a PCL 6 job a special sequence of 8 bytes has to be added. He added it by a filter to the output of Ghostscript's "pxlmono" driver and from then on the printer worked (Implemented as the "pxl1010" driver on this site).

That "pxl1010" driver is https://www.openprinting.org/driver/pxl1010, but it says its deprecated, and hplip (https://www.openprinting.org/driver/hplip/) is the recommended replacement.


Similar problem printing to an old (c.2003) HP LaserJet 1010 from Lubuntu 16.04.5 LTS running on a Dell Inspiron 15. HPLIP 3.18.12 finds the printer and installs it but when printing only blank pages come out.

To get it working I deleted the printer from HPLIP and installed it through the CUPS web interface http://localhost:631 and chose the HP LaserJet 1010 - CUPS+Gutenprint v5.2.11 under Make & Model options, not the HP LaserJet 1010, hpcups 3.18.12 (en) option/s.

This does work but occasionally one gets a long delay on a print job and a blank page with "Unsupported Personality: PCL" printed at the top. As described below, the only solution to this seems to be to turn the printer off and on again, and retry the print job.

(http://www.openprinting.org/printer/HP/HP-LaserJet_1010 "Unfortunately, the new LaserJet 1010/1012 series seems not to be absolutely compatible with older HP printers or it has a firmware bug. Sometimes it happens that the printer stops working and reports the error "Unsupported Personality: PCL". It only continues working when one kills the job and power-cycles the printer.")

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .