0

I've been having this issue with my cursor lately where my cursor is squished and has those colorful bars under it, and I can't seem to figure out what to do. I'm also not sure what would have caused my computer to suddenly start doing this.

Here is a picture I had to take with my phone, more on that later. //phone picture

I'm currently running Ubuntu 14.04 with the MATE desktop environment. My cursor did not do this when I installed MATE onto my computer, and even reverting back to earlier kernels and updates doesn't seem to fix it. I've had Ubuntu installed on my computer for almost a year now, and I've used Linux (primarily CentOS minimum and Ubuntu) for some time now.

My current computer is an older (approx 2-3 years) Lenovo G50-45 with 16gb ram, and AMD R5/A8 hardware.

I haven't changed any drivers, they are the same as when I installed Ubuntu.

//screenshot

What's most curious is that a screenshot (the one I posted of my desktop) shows the cursor to be normal when it's not.

I've tried:

-updating/upgrading and restarting

-autoremove (worth a try)

-sudo apt-get install --fix-broken

-trying older kernels from GRUB

-Ctrl+Alt+F1 then Ctrl+Alt+F7

-reverting back to an earlier state

-removing the desktop environment I use and re-installing

-removing all other desktop environments, and leaving just MATE

-resizing my desktop, changing my cursor and theme

I'm thinking at this point the only thing left to do is back up my stuff and re-install linux. I'm currently in college and busy so I'd rather not spend valuable hours starting over unless I had no other choice.

Are there any other things I may be overlooking?

  • Does the problem occur in both CentOS and Ubuntu? Have you checked for firmware/software updates for your video card? Cheers, Al – heynnema Oct 17 '16 at 23:11
  • This particular computer has only Ubuntu on it, I meant I have used both CentOS and Ubuntu primarily. I have checked for both and it seems to be up to date – Nicholas Grogg Oct 18 '16 at 18:37
  • If you've got an AMD/ATI/Nvidia card, then you need to make sure that the firmware and software is up to date. What appears in the Additional Drivers tab of the Software & Updates app? Do you have Intel processors? Cheers, Al – heynnema Oct 18 '16 at 18:50
  • I have an AMD video card (An R5 belonging to I believe the Mullins series), and I've checked that all video card drivers are up to date. I've also tried switching back and forth between fglrx and x.org video drivers with no success. I also tried sudo apt-get install -f between each driver switch to see if there were any problems. Still no fix. – Nicholas Grogg Oct 19 '16 at 21:45
  • There's a BIOS update available for your machine. It came out 2 days ago. Have you installed it yet? It's at support.lenovo.com/us/en/products/Laptops-and-netbooks/… Cheers, Al – heynnema Oct 19 '16 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.