0

Good evening!

SITUATION: I ran into a quite stupid problem, I know my LVM boot partition is not cleaning up properly old kernels and I have to do it manually, thus I forgot last time and now I am somehow stuck with a half-way installed linux-image-4.4.0-43. At first, I had the issue that when trying to update I had the message "not enough space" (something like that), so I followed the steps from THIS LINK. uname -r returns the current running kernel is 4.4.0-42 (fine) when is ran the dpkg -l command I get a slightly different list:

pi  linux-image-4.4.0-34-generic                4.4.0-34.53                                                 amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-36-generic                4.4.0-36.55                                                 amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
pF  linux-image-4.4.0-43-generic                4.4.0-43.63                                                 amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP

if I want to remove the last entry for the kernel 4.4.0-43 I always get unresolved dependencies (basically the 4.4.0-43-generic being dependent on the 4.4.0-43 packages)

PROBLEM: when I boot my PC now the booting stops and I have to press power button for few seconds and restart the machine, so I get into GRUB and can manually select the 4.4..0-42-generic kernel from the list the 43 kernel is the top entry in the list to select from in GRUB.

ASSUMPTION: my assumption is now that the new kernel is somewhat half way installed but not working properly. this is based on the output of the update-grub2 command:

Warnung: Werte ungleich 0 für »GRUB_TIMEOUT« werden, falls »GRUB_HIDDEN_TIMEOUT« aktiviert ist, nicht mehr unterstützt.
Linux-Abbild gefunden: /boot/vmlinuz-4.4.0-43-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.4.0-42-generic
initrd-Abbild gefunden: /boot/initrd.img-4.4.0-42-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.4.0-36-generic
initrd-Abbild gefunden: /boot/initrd.img-4.4.0-36-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.4.0-34-generic
initrd-Abbild gefunden: /boot/initrd.img-4.4.0-34-generic
Adding boot menu entry for EFI firmware configuration

QUESTION: how do I fix this? I assume I have to remove somehow the new kernel entry and re-install it - but I am stuck/lost. I have read so many posts and links already, I am totally confused (not the biggest Linux pro - I guess you figured that already)

Any help is appreciated, thanks

UPDATE asked for: ls -alh /boot

drwxr-xr-x  5 root root 3,0K Okt 14 17:16 .
drwxr-xr-x 25 root root 4,0K Okt 14 17:16 ..
-rw-r--r--  1 root root 1,2M Jul 27 23:28 abi-4.4.0-34-generic
-rw-r--r--  1 root root 1,2M Aug 11 21:58 abi-4.4.0-36-generic
-rw-r--r--  1 root root 1,2M Okt  8 04:15 abi-4.4.0-42-generic
-rw-r--r--  1 root root 1,2M Okt 12 17:47 abi-4.4.0-43-generic
-rw-r--r--  1 root root 186K Jul 27 23:28 config-4.4.0-34-generic
-rw-r--r--  1 root root 186K Aug 11 21:58 config-4.4.0-36-generic
-rw-r--r--  1 root root 186K Okt  8 04:15 config-4.4.0-42-generic
-rw-r--r--  1 root root 186K Okt 12 17:47 config-4.4.0-43-generic
drwxr-xr-x  3 root root 4,0K Jan  1  1970 efi
drwxr-xr-x  5 root root 1,0K Okt 17 19:49 grub
-rw-r--r--  1 root root  35M Sep  1 18:55 initrd.img-4.4.0-34-generic
-rw-r--r--  1 root root  35M Sep 16 17:23 initrd.img-4.4.0-36-generic
-rw-r--r--  1 root root  37M Okt 13 18:38 initrd.img-4.4.0-42-generic
drwx------  2 root root  12K Apr 14  2016 lost+found
-rw-r--r--  1 root root 179K Jan 28  2016 memtest86+.bin
-rw-r--r--  1 root root 181K Jan 28  2016 memtest86+.elf
-rw-r--r--  1 root root 181K Jan 28  2016 memtest86+_multiboot.bin
-rw-------  1 root root 3,7M Jul 27 23:28 System.map-4.4.0-34-generic
-rw-------  1 root root 3,7M Aug 11 21:58 System.map-4.4.0-36-generic
-rw-------  1 root root 3,7M Okt  8 04:15 System.map-4.4.0-42-generic
-rw-------  1 root root 3,7M Okt 12 17:47 System.map-4.4.0-43-generic
-rw-------  1 root root 6,8M Jul 27 23:28 vmlinuz-4.4.0-34-generic
-rw-------  1 root root 6,8M Aug 11 21:58 vmlinuz-4.4.0-36-generic
-rw-------  1 root root 6,8M Sep  3 09:49 vmlinuz-4.4.0-36-generic.efi.signed
-rw-------  1 root root 6,8M Okt  8 04:15 vmlinuz-4.4.0-42-generic
-rw-------  1 root root 6,8M Okt 13 18:38 vmlinuz-4.4.0-42-generic.efi.signed
-rw-------  1 root root 6,8M Okt 12 17:47 vmlinuz-4.4.0-43-generic

df -hTa /boot

/dev/sdb2      ext2  237M    178M   47M   80% /boot

UPDATE2: the removal of 4.4.0-34-generic and 4.4.0-36-generic has worked, I guess. reinstall of 4.4.0-43-generic seems to be succesful from what I can understand.

  • Can you add the output of ls -alh /boot and df -hTa /boot to your question. Sometimes dkms leaves backup initrd which also take a lot of space and are not needed. – Thomas Oct 17 '16 at 18:48
  • updated with info. – satansbraten Oct 17 '16 at 19:02
  • 1
    Can you remove kernels linux-image-4.4.0-34-generic and linux-image-4.4.0-36-generic with apt-get purge linux-image-4.4.0-34-generic linux-image-4.4.0-36-generic? After that, try to run apt-get install --reinstall linux-image-4.4.0-43-generic. – Thomas Oct 17 '16 at 19:20
  • Will update later – satansbraten Oct 18 '16 at 5:22
0

Thanks a lot @Thomas.

the removal of the last two remaining linux images and in the last consequence the

apt-get install --reinstall linux-image-4.4.0-43-generic

solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.