1

I am using virtualbox with host windows 10 and guest Ubuntu 16.04 .

I have a shared folder that I mount with: sudo mount.vboxsf -o rw Documents_win ~/Shared/

Everything is fine but then the mounted folder (Shared) has only reading permission.

How can I mount it in order to have writing permission as well?

EDIT: These are the permission that I have on the folder:

luca@luca-VirtualBox:~$ ls -l
total 52
drwxr-xr-x 2 luca luca 4096 Oct 17 16:03 Desktop
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Documents
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Downloads
-rw-r--r-- 1 luca luca 8980 Oct 17 13:36 examples.desktop
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Music
drwxrwxr-x 3 luca luca 4096 Oct 17 16:59 MyApps
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Pictures
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Public
drwxrwxr-x 2 luca luca 4096 Oct 17 16:24 Shared
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Templates
drwxr-xr-x 2 luca luca 4096 Oct 17 13:41 Videos
luca@luca-VirtualBox:~$ ls -l Shared/
total 0
  • What permissions and ownership do you have on the Shared folder? Cheers, Al – heynnema Oct 17 '16 at 21:20
  • The folder Shared is in my home. These are the permission that I have from the guest OS. – Donbeo Oct 18 '16 at 8:49
  • 1
    Did you 1) install guest additions, 2) in settings/shared folder uncheck the read only in edit mode, 3) add yourself to the vboxsf group and logout/login? If one of these works, let me know and I'll put more detail in an answer. Cheers, Al – heynnema Oct 18 '16 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.