10

Since I upgraded to from 16.04 to 16.10, gedit has strange new "feature": its background is totally transparent.

like here

Where can this come from ?

Notice I'm using Unity and don't have any specific gnome package installed besides what comes by default.
Notice also that in 16.04 I used the Vivacious theme from ravefinity PPA, but I had to go back to Ambiance as Vivacious was broken in 16.10. Maybe it's related.

[EDIT] changing the 'Fonts and Colors' in gedit to any theme other than default (Kate, Solarized, Oblivion, etc..) solves the issue. So there must be a faulty gtksourview file in my home somewhare, but I can't find it...

  • @CelticWarrior any idea how to suppress theme remnants on my user account? – alci Oct 17 '16 at 13:23
  • Perhaps using ppa-purge against the theme PPA to revert all changes. – user589808 Oct 17 '16 at 15:44
  • I believe the latest revision you made seems to add the "solution" to the question. So, I'll recommend you to kindly add that as answer and remove the solution from the question body. Thanks :) – Kulfy Jan 9 at 16:28
  • @Kulfy actually, the latest edit only provides a workaround, and doesn't allow the use of the default theme, and they confirm that there's still a problem. My answer IS the true correct answer. – heynnema Jan 21 at 14:30
19

I had the same problem. After much digging, I found that the file $HOME/.xinputrc was the cause. I just deleted this file with:

rm ~/.xinputrc

The contents of the file are:

# im-config(8) generated on Tue, 18 Aug 2015 16:56:49 -0700
run_im ibus
im-config signature: fef625e6f3691095fd8f4a2f315e85f7  -

After deleting the above file you will need to logout and log back in for changes to take effect (or just reboot).

  • 1
    @heynnema works for me too, but I don't understand how this is related at all. Do you have any insight on what happens ? – alci Oct 24 '16 at 8:12
  • It has something to do with the "input method", which is something you could set from System Settings in previous versions of Ubuntu. I still don't know why it did what it did to gedit though. Cheers, Al – heynnema Oct 24 '16 at 11:26
  • 4
    reboot after that to make changes update – mrtuvn Nov 7 '16 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.