2

I'm experiencing same problem on two different computers, running Ubuntu 14.04 LTS. I am copying from server (also 14.04) over SSHFS large amount of data and files (few gigabytes). One computer is connected via LAN, second is over internet.

Most of the times everything is OK. Data are copied and everything works as expected. But sometimes during data copying I get "Software caused connection abort" error and process ends. And mounted SSHFS gets into "frozen" state. And the only thing which helps is manually doing `umount /mnt/share' and 'mount /mnt/share'.

I understand that some things may happen on network, that sometimes packet get lost and connection is dropped. But I would like to automatically handle this situation, so that "frozen" share is remounted automatically when it is needed.

Is there any simple solution to this ?

EDIT: I am using this SSHFS options in /etc/fstab: auto,defaults,users,reconnect,allow_other

  • I am having the same problem. After seeing the "Software caused connection abort" message, I then see "Transport endpoint is not connected" for all subsequent access to the mount point. I have these options for fstab "reconnect,ServerAliveInterval=15,ServerAliveCountMax=3" as well, but it doesn't seem to help. Were you able to find a cure to this? – Soichi Hayashi Jun 5 at 13:38
  • Unfortunately not :-( – Frodik Jun 6 at 4:38
0

Which sshfs options are you using and which have you tried ?

Here is a list

https://linux.die.net/man/1/sshfs

you can add them to /etc/fstab or specify them on the command line.

| improve this answer | |
  • try it again but with -o sshfs_debug to get more info on the failure – Amias Oct 24 '16 at 12:54
  • you might also want to try debugging the sshfs fuse driver , heres a guide blog.jeffli.me/blog/2014/08/30/… – Amias Oct 24 '16 at 13:37
0

From what I could find you need 2 more options for your mount.

From there they explain ServerAliveCountMax and ServerAliveInterval.

If, for example, ServerAliveInterval (see below) is set to 15 and ServerAliveCountMax is left at the default, if the server becomes unresponsive, ssh will disconnect after approximately 45 seconds.

That should do it, tune up as you need.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.