1

I'm having trouble with VirtualBox within Ubuntu. I want to create a 64-bit virtual machine, but VB only gives me 32-bit options (see screenshot). I installed VirtualBox on macOS, and it works fine. However, when I installed VB within Ubuntu I got this problem.

In fact, I wanted to install gnome-software (with Virtualbox) on Ubuntu in following this YouTube tutorial, but it is not possible so far.

I have a Macbook Pro (Mid-2012, 13-inch), and Ubuntu 64-bit with installed with VirtualBox

The problem seems to be the Vt/x is disabled. I thought it was the one on the OS X. According to the Apple Support, it couldn't be modified from OS X. So we have to enable from VB.

Question : Could anyone be able to tell me how to enable virtualization from VB?

P.S. It is a bit weird, but I installed Ubuntu with VB on macOS, and now I want to install gnome-software with VB within Ubuntu.

4
  • 1
    Just to clarify: Host OS is OSX, hardware is Apple, and Vt/x is enabled in BIOS? Do you dual boot OSX and Ubuntu? What version and architecture of Ubuntu would that be?
    – Takkat
    Oct 17, 2016 at 8:36
  • @Takkat - Macs don't have a BIOS. Oct 17, 2016 at 14:42
  • I know, it is a UEFI or just EFI boot.
    – Law
    Oct 17, 2016 at 14:55
  • Still unclear. Do you try to set up a nested VM? This is at present only possible with software virtualization (i.e. 32-bit). See virtualbox.org/ticket/4032
    – Takkat
    Oct 17, 2016 at 16:29

1 Answer 1

-1

Try this link https://forum.parallels.com/threads/how-to-enable-vt-aka-vtx-or-vt-x-with-refit-and-vmx-var-set-efi.3273/ It should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.