2

I just installed Ubuntu 16.10 on my desktop and have a USB deathadder. The problem is I can't see where the cursor actually is because it appears only in the top left of my screen. The mouse still moves but the cursor graphic doesn't follow

  • I am suffering from this same issue. If it is any help, this happened right after I installed a new GTX 1070 GPU. This issue happens in the installer or when ubuntu is booted from live-USB for 16.10. – Thomas Antony Nov 14 '16 at 22:54
  • 1
    @ThomasAntony yeah I have a GTX 1070 and I can't get ANY distro of ubuntu to properly work with it. It is super frustrating! – Dibesjr Nov 14 '16 at 23:15
  • I could get it to move if I added nomodeset in the boot options. Of course, this makes the graphics reset to low-res. But I could at least get through the installer. I guess this means there is some specific driver that is causing this issue? I will let you know if this persists after the installation is done. This could be specific to 16.10. I installed Linux Mint which I assume is based on the LTS version and the mouse worked fine. – Thomas Antony Nov 16 '16 at 3:09
  • Just found this: askubuntu.com/questions/838692/… Could fix our issues. – Thomas Antony Nov 16 '16 at 3:15
2

I was able to fix this by installing the nvidia-370 drivers. Try the following steps:

  1. Press Ctrl+Alt+F1 at the login screen. This will drop you down into a console where you can login to your user account.

  2. Run sudo service lightdm stop

  3. Use the following commands to download and install nvidia-370. Make sure you are connected to the internet: sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get update sudo apt-get install nvidia-370 nvidia-settings
  4. Disable the nouveau driver. This step may be unnecessary but I did it anyway. Edit the file /etc/modprobe.d/blacklist.conf and add blacklist nouveau at the bottom. Save and Exit.

  5. Run the command sudo update-initramfs -u

  6. Restart with sudo reboot
  • I will try this and let you know if this works for me! Would be fantastic :D – Dibesjr Dec 1 '16 at 16:52
0

try rebooting. That happened to me too. I went trough this problem on xubuntu. I tried rebooting and the curser reappeared. Thats all I know. I hope this helps!

  • 1
    I've tried rebooting a lot. The cursor is there, just the graphic is stuck in the top left corner. I can still use the mouse as if it works I just can't see where it is! – Dibesjr Oct 17 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.